# CVE-2026-66008: Parse Server 9.0.0 Information Disclosure via GraphQL Error Messages

> Unauthenticated attackers can reveal hidden schema class names via GraphQL error messages in Parse Server, bypassing schema-hiding protections.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jul 2026
- **Updated:** 28 Jul 2026
- **Also known as:** BIT-parse-2026-66008, GHSA-5fc6-2494-x3q8, GHSA-r2g6-4f6j-f6rf

## What is CVE-2026-66008?

CVE-2026-66008 is a medium-severity vulnerability in parse-community parse-server, published on 24 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Parse Server versions >= 9.0.0 before 9.10.0-alpha.6 and >= 8.2.2 before 8.6.87 disclose Pointer and Relation target class names through GraphQL validation and input-coercion error messages when public schema introspection is disabled (graphQLPublicIntrospection: false, the default). Because these errors are produced before authentication, authorization, or any resolver runs, an unauthenticated client possessing only the public application ID can trigger errors on Pointer or Relation fields to reconstruct hidden schema class names, partially defeating the schema-hiding protection. Only schema metadata (class names) is exposed; no object data, credentials, or user records are disclosed.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2026-66008?

1 open source package ship an affected version, including parse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse` | Bitnami | From 8.2.2 | 8.6.87, 9.10.0 |

## How do I fix CVE-2026-66008?

Upgrade parse to a fixed version for your release line: 8.6.87 or 9.10.0.

## Is CVE-2026-66008 being exploited?

There is no known exploitation of CVE-2026-66008 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-66008 and fix it if it is affected.

What it is: CVE-2026-66008 is a medium-severity vulnerability in parse-community parse-server, published on 24 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-66008 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse (Bitnami): affected from 8.2.2; fixed in 8.6.87, 9.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-66008/ (Markdown: https://insights.sbomify.com/CVE-2026-66008/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-66008
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-66008
- OSV: https://osv.dev/vulnerability/CVE-2026-66008

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-66008/
Summaries are generated and may contain mistakes; the official description above is the record.
