{"answers":{"affected":"1 open source package ship an affected version, including parse.","exploited":"There is no known exploitation of CVE-2026-66009 in the wild and no public exploit code.","fix":"Upgrade parse to a fixed version for your release line: 8.6.86 or 9.10.0.","what":"CVE-2026-66009 is a medium-severity vulnerability in parse-community parse-server, published on 24 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-66009 and fix it if it is affected.\n\nWhat it is: CVE-2026-66009 is a medium-severity vulnerability in parse-community parse-server, published on 24 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-66009 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- parse (Bitnami): affected from 8.2.2; fixed in 8.6.86, 9.10.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-66009/ (Markdown: https://insights.sbomify.com/CVE-2026-66009/index.md)","id":"CVE-2026-66009","markdown":"https://insights.sbomify.com/CVE-2026-66009/index.md","name":"CVE-2026-66009","record":{"aliases":["BIT-parse-2026-66009","GHSA-2fgh-8j2g-w354","GHSA-v9g2-r7jf-7j84"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Parse Server","requires_auth":"none","summary":"Attackers can discover custom field names via GraphQL errors despite disabled introspection, exposing schema details.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-209","name":"Generation of Error Message Containing Sensitive Information"}],"description":"Parse Server versions \u003e= 9.0.0 before 9.10.0-alpha.5 and \u003e= 8.2.2 before 8.6.86 return GraphQL validation error messages that name required custom input fields even when public introspection is disabled (graphQLPublicIntrospection: false, the default). A client holding only the public application id — with no user session, master key, or maintenance key — can trigger validation errors to learn the names of required (non-null) custom fields on classes it already references by name, partially defeating the schema-hiding intent of disabling public introspection. No stored data, credentials, optional field names, unreferenced class names, or Cloud Code function names are exposed.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Parse Server 9.0.0 Information Disclosure via GraphQL Error Messages","id":"CVE-2026-66009","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":1,"n_references":2,"next":{"headline":"DOMPurify before 3.4.12 Hook Bypass via CUSTOM_ELEMENT_HANDLING","id":"CVE-2026-66010"},"packages":[{"ecosystem":"Bitnami","fixed":["8.6.86","9.10.0"],"introduced":["8.2.2","9.0.0"],"last_affected":[],"package":"parse","purl":"pkg:bitnami/parse","source":"BIT-parse-2026-66009"}],"prev":{"headline":"Parse Server 9.0.0 Information Disclosure via GraphQL Error Messages","id":"CVE-2026-66008"},"products":["parse-server"],"published":"2026-07-24","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-28","vendors":["parse-community"]},"summary":"Attackers can discover custom field names via GraphQL errors despite disabled introspection, exposing schema details.","url":"https://insights.sbomify.com/CVE-2026-66009/"}