# CVE-2026-66009: Parse Server 9.0.0 Information Disclosure via GraphQL Error Messages

> Attackers can discover custom field names via GraphQL errors despite disabled introspection, exposing schema details.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jul 2026
- **Updated:** 28 Jul 2026
- **Also known as:** BIT-parse-2026-66009, GHSA-2fgh-8j2g-w354, GHSA-v9g2-r7jf-7j84

## What is CVE-2026-66009?

CVE-2026-66009 is a medium-severity vulnerability in parse-community parse-server, published on 24 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Parse Server versions >= 9.0.0 before 9.10.0-alpha.5 and >= 8.2.2 before 8.6.86 return GraphQL validation error messages that name required custom input fields even when public introspection is disabled (graphQLPublicIntrospection: false, the default). A client holding only the public application id — with no user session, master key, or maintenance key — can trigger validation errors to learn the names of required (non-null) custom fields on classes it already references by name, partially defeating the schema-hiding intent of disabling public introspection. No stored data, credentials, optional field names, unreferenced class names, or Cloud Code function names are exposed.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2026-66009?

1 open source package ship an affected version, including parse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse` | Bitnami | From 8.2.2 | 8.6.86, 9.10.0 |

## How do I fix CVE-2026-66009?

Upgrade parse to a fixed version for your release line: 8.6.86 or 9.10.0.

## Is CVE-2026-66009 being exploited?

There is no known exploitation of CVE-2026-66009 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-66009 and fix it if it is affected.

What it is: CVE-2026-66009 is a medium-severity vulnerability in parse-community parse-server, published on 24 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-66009 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse (Bitnami): affected from 8.2.2; fixed in 8.6.86, 9.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-66009/ (Markdown: https://insights.sbomify.com/CVE-2026-66009/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-66009
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-66009
- OSV: https://osv.dev/vulnerability/CVE-2026-66009

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-66009/
Summaries are generated and may contain mistakes; the official description above is the record.
