# CVE-2026-66058: Frappe: Unrestricted access to a Document Follow API

> Authenticated users can bypass authorization checks to modify document follow settings in the Frappe framework.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 Aug 2026
- **Updated:** 10 Aug 2026
- **Also known as:** GHSA-fgx7-fvpx-mw3g

## What is CVE-2026-66058?

CVE-2026-66058 is a medium-severity missing authorization vulnerability in frappe, published on 7 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Frappe is a full-stack web application framework. Prior to 16.20.0 and 15.112.0, unrestricted access to a Document Follow API (update_follow) is possible for an authenticated user.
This issue is fixed in versions 16.20.0 and 15.112.0.

Weakness: CWE-862 (Missing Authorization), CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-66058?


## How do I fix CVE-2026-66058?

No fix has been published for CVE-2026-66058 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-66058 being exploited?

There is no known exploitation of CVE-2026-66058 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-66058 and fix it if it is affected.

What it is: CVE-2026-66058 is a medium-severity missing authorization vulnerability in frappe, published on 7 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-66058 in the wild and no public exploit code.

Affected product: frappe. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-66058/ (Markdown: https://insights.sbomify.com/CVE-2026-66058/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-66058
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-66058
- OSV: https://osv.dev/vulnerability/CVE-2026-66058

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-66058/
Summaries are generated and may contain mistakes; the official description above is the record.
