# CVE-2026-66062: SvelteKit: ReDoS (O(n^2)) in content negotiation — unauthenticated DoS via the Accept header

> An attacker can cause denial of service in SvelteKit applications by sending a malicious Accept header that triggers quadratic backtracking in the regex parser.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Aug 2026
- **Updated:** 7 Aug 2026
- **Also known as:** GHSA-29g2-3rmr-qm68

## What is CVE-2026-66062?

CVE-2026-66062 is a medium-severity denial of service vulnerability in sveltejs kit, published on 7 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SvelteKit is a framework for rapidly developing robust, performant web applications using Svelte. Prior to 2.70.2, the content negotiation header parser used by SvelteKit's request handling (for headers such as Accept) uses a regular expression vulnerable to quadratic backtracking, so a maliciously crafted header value can cause excessive CPU consumption and degrade or deny service. Version 2.70.2 fixes the issue.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-66062?

2 open source packages ship an affected version, including @sveltejs/kit.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@sveltejs/kit` | npm | All versions | 2.70.2 |
| `@sveltejs/kit` | npm | All versions | 2.70.2 |

## How do I fix CVE-2026-66062?

Upgrade @sveltejs/kit to 2.70.2 or later.

## Is CVE-2026-66062 being exploited?

There is no known exploitation of CVE-2026-66062 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-66062 and fix it if it is affected.

What it is: CVE-2026-66062 is a medium-severity denial of service vulnerability in sveltejs kit, published on 7 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-66062 in the wild and no public exploit code.

Affected packages and fixed versions:
- @sveltejs/kit (npm): affected all versions; fixed in 2.70.2
- @sveltejs/kit (npm): affected all versions; fixed in 2.70.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-66062/ (Markdown: https://insights.sbomify.com/CVE-2026-66062/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-66062
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-66062
- OSV: https://osv.dev/vulnerability/CVE-2026-66062

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-66062/
Summaries are generated and may contain mistakes; the official description above is the record.
