CVE-2026-66067 RabbitMQ: Stream protocol skips per vhost per user connection limits
Authenticated users can bypass per-user and per-vhost connection limits by using the stream protocol instead of AMQP.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-66067?
CVE-2026-66067 is a medium-severity vulnerability in rabbitmq-server, published on 23 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
RabbitMQ is a messaging and streaming broker. Prior to versions 4.2.7 and 4.3.1, The stream open handler calls only check_vhost_access; it omits the node/vhost/user connection-limit checks that rabbit_reader performs for AMQP. A developer %% FIXME comment at the cited line explicitly acknowledges the gap. No compensating enforcement exists in connection tracking or elsewhere in rabbitmq_stream. An authenticated tenant can fully bypass operator-configured per-user and per-vhost connection caps by connecting via port 5552 instead of 5672. Preconditions include rabbitmq_stream plugin enabled Authenticated stream-protocol credentials Operator relies on per-user/per-vhost connection limits for tenant isolation. This issue is fixed in versions 4.2.7 and 4.3.1.
Weakness: CWE-770
Which versions are affected by CVE-2026-66067?
1 open source package ship an affected version, including rabbitmq.
| Package | Affected | Fixed in |
|---|---|---|
rabbitmq Bitnami | From 4.2.0 | 4.2.7, 4.3.1 |
How do I fix CVE-2026-66067?
Upgrade rabbitmq to a fixed version for your release line: 4.2.7 or 4.3.1.
Is CVE-2026-66067 being exploited?
There is no known exploitation of CVE-2026-66067 in the wild and no public exploit code.
Sources
Also known as AZL-105762, BIT-rabbitmq-2026-66067, DEBIAN-CVE-2026-66067, GHSA-hwqx-2gfg-89qf, UBUNTU-CVE-2026-66067.