{"answers":{"affected":"1 open source package ship an affected version, including rabbitmq.","exploited":"There is no known exploitation of CVE-2026-66067 in the wild and no public exploit code.","fix":"Upgrade rabbitmq to a fixed version for your release line: 4.2.7 or 4.3.1.","what":"CVE-2026-66067 is a medium-severity vulnerability in rabbitmq-server, published on 23 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-66067 and fix it if it is affected.\n\nWhat it is: CVE-2026-66067 is a medium-severity vulnerability in rabbitmq-server, published on 23 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-66067 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rabbitmq (Bitnami): affected from 4.2.0; fixed in 4.2.7, 4.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-66067/ (Markdown: https://insights.sbomify.com/CVE-2026-66067/index.md)","id":"CVE-2026-66067","markdown":"https://insights.sbomify.com/CVE-2026-66067/index.md","name":"CVE-2026-66067","record":{"aliases":["AZL-105762","BIT-rabbitmq-2026-66067","DEBIAN-CVE-2026-66067","GHSA-hwqx-2gfg-89qf","UBUNTU-CVE-2026-66067"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"RabbitMQ message broker","requires_auth":"low_privilege","summary":"Authenticated users can bypass per-user and per-vhost connection limits by using the stream protocol instead of AMQP.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"RabbitMQ is a messaging and streaming broker. Prior to versions 4.2.7 and 4.3.1, The stream open handler calls only check_vhost_access; it omits the node/vhost/user connection-limit checks that rabbit_reader performs for AMQP. A developer %% FIXME comment at the cited line explicitly acknowledges the gap. No compensating enforcement exists in connection tracking or elsewhere in rabbitmq_stream. An authenticated tenant can fully bypass operator-configured per-user and per-vhost connection caps by connecting via port 5552 instead of 5672. Preconditions include rabbitmq_stream plugin enabled Authenticated stream-protocol credentials Operator relies on per-user/per-vhost connection limits for tenant isolation. This issue is fixed in versions 4.2.7 and 4.3.1.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"RabbitMQ: Stream protocol skips per vhost per user connection limits","id":"CVE-2026-66067","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":1,"n_references":3,"next":{"headline":"RabbitMQ: Shovel DEBUG log of full state exposes decrypted URIs","id":"CVE-2026-66068"},"packages":[{"ecosystem":"Bitnami","fixed":["4.2.7","4.3.1"],"introduced":["4.2.0","4.3.0"],"last_affected":[],"package":"rabbitmq","purl":"pkg:bitnami/rabbitmq","source":"BIT-rabbitmq-2026-66067"}],"prev":{"headline":"Action Pack: Possible arbitrary file read and remote code execution in Active Storage variant processing","id":"CVE-2026-66066"},"products":["rabbitmq-server"],"published":"2026-09-23","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-24","vendors":["rabbitmq"]},"summary":"Authenticated users can bypass per-user and per-vhost connection limits by using the stream protocol instead of AMQP.","url":"https://insights.sbomify.com/CVE-2026-66067/"}