# CVE-2026-66067: RabbitMQ: Stream protocol skips per vhost per user connection limits

> Authenticated users can bypass per-user and per-vhost connection limits by using the stream protocol instead of AMQP.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Sep 2026
- **Updated:** 24 Sep 2026
- **Also known as:** AZL-105762, BIT-rabbitmq-2026-66067, DEBIAN-CVE-2026-66067, GHSA-hwqx-2gfg-89qf, UBUNTU-CVE-2026-66067

## What is CVE-2026-66067?

CVE-2026-66067 is a medium-severity vulnerability in rabbitmq-server, published on 23 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

RabbitMQ is a messaging and streaming broker. Prior to versions 4.2.7 and 4.3.1, The stream open handler calls only check_vhost_access; it omits the node/vhost/user connection-limit checks that rabbit_reader performs for AMQP. A developer %% FIXME comment at the cited line explicitly acknowledges the gap. No compensating enforcement exists in connection tracking or elsewhere in rabbitmq_stream. An authenticated tenant can fully bypass operator-configured per-user and per-vhost connection caps by connecting via port 5552 instead of 5672. Preconditions include rabbitmq_stream plugin enabled Authenticated stream-protocol credentials Operator relies on per-user/per-vhost connection limits for tenant isolation. This issue is fixed in versions 4.2.7 and 4.3.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-66067?

1 open source package ship an affected version, including rabbitmq.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rabbitmq` | Bitnami | From 4.2.0 | 4.2.7, 4.3.1 |

## How do I fix CVE-2026-66067?

Upgrade rabbitmq to a fixed version for your release line: 4.2.7 or 4.3.1.

## Is CVE-2026-66067 being exploited?

There is no known exploitation of CVE-2026-66067 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-66067 and fix it if it is affected.

What it is: CVE-2026-66067 is a medium-severity vulnerability in rabbitmq-server, published on 23 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-66067 in the wild and no public exploit code.

Affected packages and fixed versions:
- rabbitmq (Bitnami): affected from 4.2.0; fixed in 4.2.7, 4.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-66067/ (Markdown: https://insights.sbomify.com/CVE-2026-66067/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-66067
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-66067
- OSV: https://osv.dev/vulnerability/CVE-2026-66067

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-66067/
Summaries are generated and may contain mistakes; the official description above is the record.
