# CVE-2026-66069: RabbitMQ: Monitoring-tag DELETE of auth-attempt metrics

> A monitoring-tagged user can reset authentication attempt counters, erasing brute-force evidence, due to missing authorization checks in the management API.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Sep 2026
- **Updated:** 24 Sep 2026
- **Also known as:** AZL-105774, BIT-rabbitmq-2026-66069, DEBIAN-CVE-2026-66069, GHSA-fhwq-9rvh-prj2, UBUNTU-CVE-2026-66069

## What is CVE-2026-66069?

CVE-2026-66069 is a low-severity missing authorization vulnerability in rabbitmq-server, published on 23 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

RabbitMQ is a messaging and streaming broker. Prior to versions 4.1.13, 4.2.7, and 4.3.0, is_authorized/2 uses is_authorized_monitor for all methods. DELETE resets rabbit_core_metrics:reset_auth_attempt_metrics(). Impact is cosmetic (counters only, no log erasure), but inconsistent with rabbit_mgmt_wm_reset.erl which requires admin for the analogous operation. A monitoring-tagged user can reset the per-node authentication-attempt counters via DELETE /api/auth/attempts/:node, erasing evidence of brute-force activity. The sibling endpoint wm_reset requires administrator. Preconditions include Management plugin enabled monitoring tag. This issue is fixed in versions 4.1.13, 4.2.7, and 4.3.0.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-66069?

1 open source package ship an affected version, including rabbitmq.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rabbitmq` | Bitnami | From 4.1.0 | 4.1.13, 4.2.7 |

## How do I fix CVE-2026-66069?

Upgrade rabbitmq to a fixed version for your release line: 4.1.13 or 4.2.7.

## Is CVE-2026-66069 being exploited?

There is no known exploitation of CVE-2026-66069 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-66069 and fix it if it is affected.

What it is: CVE-2026-66069 is a low-severity missing authorization vulnerability in rabbitmq-server, published on 23 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-66069 in the wild and no public exploit code.

Affected packages and fixed versions:
- rabbitmq (Bitnami): affected from 4.1.0; fixed in 4.1.13, 4.2.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-66069/ (Markdown: https://insights.sbomify.com/CVE-2026-66069/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-66069
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-66069
- OSV: https://osv.dev/vulnerability/CVE-2026-66069

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-66069/
Summaries are generated and may contain mistakes; the official description above is the record.
