# CVE-2026-66071: RabbitMQ: Atom exhaustion: OAuth2 JWT tag: scope values

> Attackers can cause memory exhaustion in RabbitMQ by supplying unique OAuth2 JWT scope values, leading to denial of service.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Sep 2026
- **Updated:** 25 Sep 2026
- **Also known as:** AZL-105299, BIT-rabbitmq-2026-66071, DEBIAN-CVE-2026-66071, GHSA-89p2-f5cv-x5cg, UBUNTU-CVE-2026-66071

## What is CVE-2026-66071?

CVE-2026-66071 is a medium-severity denial of service vulnerability in Broadcom Rabbitmq Server, published on 25 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

RabbitMQ is a messaging and streaming broker. From 3.13.0 until 3.13.15 and 4.0.22 and 4.1.11 and 4.2.6 and 4.3.1, Atom exhaustion: OAuth2 JWT tag: scope values. extractscopes/1 parses scopes of the form .tag: and calls rabbitdatacoercion:toatom() to convert to a tag atom. The token signature is verified first, so the attacker cannot forge scopes , but in IdP configurations where scope content is user-influenced, each login with a novel tag value leaks one In deployments where users can influence the scopes included in their IdP-issued JWT rabbitmqauthbackendoauth2 enabled IdP permits attacker-influenced scope values in signed tokens. This issue is fixed in versions 3.13.15 and 4.0.22 and 4.1.11 and 4.2.6 and 4.3.1.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-66071?

1 open source package ship an affected version, including rabbitmq. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rabbitmq` | Bitnami | From 3.13.0 | 3.13.15, 4.0.22, 4.1.11, 4.2.6, 4.3.1 |

Products: Broadcom Rabbitmq Server.

## How do I fix CVE-2026-66071?

Upgrade rabbitmq to a fixed version for your release line: 3.13.15, 4.0.22, 4.1.11 or 4.2.6.

## Is CVE-2026-66071 being exploited?

There is no known exploitation of CVE-2026-66071 in the wild and no public exploit code.

## Other vulnerabilities in Broadcom Rabbitmq Server

- [CVE-2016-9877](https://insights.sbomify.com/CVE-2016-9877/): Auth bypass in Pivotal RabbitMQ 3.x before 3.5.8 and 3.6.x before 3.6.6; RabbitMQ for PCF 1.5.x before 1.5.20, 1.6.x before 1.6.12 and 1.7.x before 1.7.7 (critical 9.8)
- [CVE-2026-67404](https://insights.sbomify.com/CVE-2026-67404/): RabbitMQ: OAuth2 silent verify_none fallback for JWKS fetch (critical 9.2)
- [CVE-2026-67231](https://insights.sbomify.com/CVE-2026-67231/): RabbitMQ: Trust-store whitelist by Issuer+Serial only (critical 9.1)
- [CVE-2026-57219](https://insights.sbomify.com/CVE-2026-57219/): Information disclosure in rabbitmq-server (high 8.7)
- [CVE-2026-67236](https://insights.sbomify.com/CVE-2026-67236/): RabbitMQ: Plaintext username:password stored in an insecure cookie after successful POST /login (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-66071 and fix it if it is affected.

What it is: CVE-2026-66071 is a medium-severity denial of service vulnerability in Broadcom Rabbitmq Server, published on 25 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-66071 in the wild and no public exploit code.

Affected packages and fixed versions:
- rabbitmq (Bitnami): affected from 3.13.0; fixed in 3.13.15, 4.0.22, 4.1.11, 4.2.6, 4.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-66071/ (Markdown: https://insights.sbomify.com/CVE-2026-66071/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-66071
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-66071
- OSV: https://osv.dev/vulnerability/CVE-2026-66071

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-66071/
Summaries are generated and may contain mistakes; the official description above is the record.
