{"answers":{"affected":"2 open source packages ship an affected version, including cockpit-hq/cockpit.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-6626 exists.","fix":"Upgrade cockpit-hq/cockpit to 2.14.0 or later.","what":"CVE-2026-6626 is a medium-severity code injection vulnerability in Cockpit-HQ Cockpit, published on 20 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-6626 and fix it if it is affected.\n\nWhat it is: CVE-2026-6626 is a medium-severity code injection vulnerability in Cockpit-HQ Cockpit, published on 20 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-6626 exists.\n\nAffected packages and fixed versions:\n- cockpit-hq/cockpit (Packagist): affected all versions; fixed in 2.14.0\n- cockpit-hq/cockpit (Packagist): affected all versions; fixed in 2.14.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-6626/ (Markdown: https://insights.sbomify.com/CVE-2026-6626/index.md)","id":"CVE-2026-6626","markdown":"https://insights.sbomify.com/CVE-2026-6626/index.md","name":"CVE-2026-6626","record":{"aliases":["GHSA-5pv2-86qj-5jf9"],"analysis":{"component_type":"web_application","fix_type":"no_fix_stated","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Cockpit CMS","requires_auth":"low_privilege","summary":"Remote attackers can inject malicious code into Cockpit CMS asset handlers to execute arbitrary commands, requiring immediate mitigation due to lack of vendor response.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-943","name":"Improper Neutralization of Special Elements in Data Query Logic"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"A vulnerability was detected in Cockpit-HQ Cockpit up to 2.13.5. Affected by this issue is some unknown functionality of the component Asset Handler/Aggregate Handler. The manipulation results in improper neutralization of special elements in data query logic. It is possible to launch the attack remotely. The exploit is now public and may be used. The vendor was contacted early about this disclosure but did not respond in any way.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Cockpit-HQ Cockpit Asset Handler/Aggregate data query logic injection","id":"CVE-2026-6626","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"WPFormify \u003c= 1.1.1 - Missing Authorization","id":"CVE-2026-6627"},"packages":[{"ecosystem":"Packagist","fixed":["2.14.0"],"introduced":["0"],"last_affected":[],"package":"cockpit-hq/cockpit","purl":null,"source":"GHSA-5pv2-86qj-5jf9"},{"ecosystem":"Packagist","fixed":["2.14.0"],"introduced":["0"],"last_affected":[],"package":"cockpit-hq/cockpit","purl":"pkg:composer/cockpit-hq/cockpit","source":"GHSA-5pv2-86qj-5jf9"}],"prev":{"headline":"Server-side request forgery in Mogu Blog v2","id":"CVE-2026-6625"},"products":["Cockpit"],"published":"2026-04-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-20","vendors":["Cockpit-HQ"]},"summary":"Remote attackers can inject malicious code into Cockpit CMS asset handlers to execute arbitrary commands, requiring immediate mitigation due to lack of vendor response.","url":"https://insights.sbomify.com/CVE-2026-6626/"}