# CVE-2026-6626: Cockpit-HQ Cockpit Asset Handler/Aggregate data query logic injection

> Remote attackers can inject malicious code into Cockpit CMS asset handlers to execute arbitrary commands, requiring immediate mitigation due to lack of vendor response.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Apr 2026
- **Updated:** 20 Apr 2026
- **Also known as:** GHSA-5pv2-86qj-5jf9

## What is CVE-2026-6626?

CVE-2026-6626 is a medium-severity code injection vulnerability in Cockpit-HQ Cockpit, published on 20 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was detected in Cockpit-HQ Cockpit up to 2.13.5. Affected by this issue is some unknown functionality of the component Asset Handler/Aggregate Handler. The manipulation results in improper neutralization of special elements in data query logic. It is possible to launch the attack remotely. The exploit is now public and may be used. The vendor was contacted early about this disclosure but did not respond in any way.

Weakness: CWE-943 (Improper Neutralization of Special Elements in Data Query Logic), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-6626?

2 open source packages ship an affected version, including cockpit-hq/cockpit.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cockpit-hq/cockpit` | Packagist | All versions | 2.14.0 |
| `cockpit-hq/cockpit` | Packagist | All versions | 2.14.0 |

## How do I fix CVE-2026-6626?

Upgrade cockpit-hq/cockpit to 2.14.0 or later.

## Is CVE-2026-6626 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-6626 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6626 and fix it if it is affected.

What it is: CVE-2026-6626 is a medium-severity code injection vulnerability in Cockpit-HQ Cockpit, published on 20 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-6626 exists.

Affected packages and fixed versions:
- cockpit-hq/cockpit (Packagist): affected all versions; fixed in 2.14.0
- cockpit-hq/cockpit (Packagist): affected all versions; fixed in 2.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6626/ (Markdown: https://insights.sbomify.com/CVE-2026-6626/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6626
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6626
- OSV: https://osv.dev/vulnerability/CVE-2026-6626

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6626/
Summaries are generated and may contain mistakes; the official description above is the record.
