{"answers":{"affected":"1 open source package ship an affected version, including nginx-gateway-fabric.","exploited":"There is no known exploitation of CVE-2026-66362 in the wild and no public exploit code.","fix":"Upgrade nginx-gateway-fabric to 2.6.8 or later.","what":"CVE-2026-66362 is a high-severity code injection vulnerability in F5 NGINX Gateway Fabric, published on 2 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-66362 and fix it if it is affected.\n\nWhat it is: CVE-2026-66362 is a high-severity code injection vulnerability in F5 NGINX Gateway Fabric, published on 2 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-66362 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nginx-gateway-fabric (Bitnami): affected from 2.5.0; fixed in 2.6.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-66362/ (Markdown: https://insights.sbomify.com/CVE-2026-66362/index.md)","id":"CVE-2026-66362","markdown":"https://insights.sbomify.com/CVE-2026-66362/index.md","name":"CVE-2026-66362","record":{"aliases":["BIT-nginx-gateway-fabric-2026-66362","GHSA-94x9-2xmh-58p8"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"NGINX Gateway Fabric","requires_auth":"low_privilege","summary":"Authenticated attackers can inject arbitrary NGINX directives via unsanitized fields in Authentication Filter resources, potentially compromising the control plane.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"f5","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-76","name":"Improper Neutralization of Equivalent Special Elements"}],"description":"Description:\nWhen NGINX Plus is configured as the data plane for NGINX Gateway Fabric, an injection vulnerability exists in the NGINX configuration generator component of NGINX Gateway Fabric. User-supplied string values from the Authentication Filter Custom Resource Definition clientID or cookieName fields, or in the clientSecret field of a Secret referenced by an Authentication Filter, are rendered directly into NGINX configuration templates without sanitization or escaping. \n\nImpact:\nAn authenticated attacker with permission to create or modify these resources may craft values that inject arbitrary NGINX configuration directives. This is a control plane issue; there is no data plane exposure.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"NGF vulnerability","id":"CVE-2026-66362","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"MZ Automation libiec61850 Out-of-bounds Read","id":"CVE-2026-66364"},"packages":[{"ecosystem":"Bitnami","fixed":["2.6.8"],"introduced":["2.5.0"],"last_affected":[],"package":"nginx-gateway-fabric","purl":"pkg:bitnami/nginx-gateway-fabric","source":"BIT-nginx-gateway-fabric-2026-66362"}],"prev":{"headline":"MZ Automation libiec61850 Out-of-bounds Read","id":"CVE-2026-66360"},"products":["NGINX Gateway Fabric"],"published":"2026-09-02","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-03","vendors":["F5"]},"summary":"Authenticated attackers can inject arbitrary NGINX directives via unsanitized fields in Authentication Filter resources, potentially compromising the control plane.","url":"https://insights.sbomify.com/CVE-2026-66362/"}