{"answers":{"affected":"1 open source package ship an affected version, including postgresql. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-6638 in the wild and no public exploit code.","fix":"Upgrade postgresql to a fixed version for your release line: 16.14.0, 17.10.0 or 18.4.0.","what":"CVE-2026-6638 is a low-severity SQL injection vulnerability in Postgresql Postgresql, published on 14 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-6638 and fix it if it is affected.\n\nWhat it is: CVE-2026-6638 is a low-severity SQL injection vulnerability in Postgresql Postgresql, published on 14 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-6638 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- postgresql (Bitnami): affected from 16.0.0; fixed in 16.14.0, 17.10.0, 18.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-6638/ (Markdown: https://insights.sbomify.com/CVE-2026-6638/index.md)","id":"CVE-2026-6638","markdown":"https://insights.sbomify.com/CVE-2026-6638/index.md","name":"CVE-2026-6638","record":{"aliases":["ALPINE-CVE-2026-6638","AZL-86825","BELL-CVE-2026-6638","BIT-postgresql-2026-6638","DEBIAN-CVE-2026-6638","ECHO-1169-1a51-1552","GHSA-3835-x2rj-c3qj","JLSEC-2026-608","MINI-hcgf-phhv-r383","MINI-jqw5-vw8q-6x78","MINI-xvh9-2q44-jxxx","UBUNTU-CVE-2026-6638"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":true,"product_category":"PostgreSQL database","requires_auth":"low_privilege","summary":"A subscriber table creator can execute arbitrary SQL with publication-side credentials via logical replication refresh, requiring an upgrade to fix.","user_interaction":"required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"PostgreSQL","cpe":[{"product":"postgresql","vendor":"postgresql"}],"cvss":{"score":3.7,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"SQL injection in PostgreSQL logical replication ALTER SUBSCRIPTION ... REFRESH PUBLICATION allows a subscriber table creator to execute arbitrary SQL with the subscription's publication-side credentials.  The attack takes effect at the next REFRESH PUBLICATION.  Within major versions 16, 17, and 18, minor versions before PostgreSQL 18.4, 17.10, and 16.14 are affected.  Versions before PostgreSQL 16 are unaffected.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PostgreSQL REFRESH PUBLICATION allows SQL injection via table name","id":"CVE-2026-6638","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"postgresql:postgresql","products":["postgresql:postgresql"],"type":"sql_injection","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Missing authorization in AI Copilot – Content Generator","id":"CVE-2026-6639"},"packages":[{"ecosystem":"Bitnami","fixed":["16.14.0","17.10.0","18.4.0"],"introduced":["16.0.0","17.0.0","18.0.0"],"last_affected":[],"package":"postgresql","purl":"pkg:bitnami/postgresql","source":"BIT-postgresql-2026-6638"}],"prev":{"headline":"PostgreSQL refint allows stack buffer overflow and SQL injection","id":"CVE-2026-6637"},"products":["PostgreSQL"],"published":"2026-05-14","related":[{"cvss_score":10,"headline":"Information disclosure in n/a","id":"CVE-2013-1902","kev_date_added":null,"published":"2013-04-04"},{"cvss_score":10,"headline":"Information disclosure in n/a","id":"CVE-2013-1903","kev_date_added":null,"published":"2013-04-04"},{"cvss_score":10,"headline":"Privilege escalation in n/a","id":"CVE-2007-3279","kev_date_added":null,"published":"2007-06-19"},{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2002-1399","kev_date_added":null,"published":"2003-01-08"},{"cvss_score":9.1,"headline":"Information disclosure in n/a","id":"CVE-2016-3065","kev_date_added":null,"published":"2016-04-11"},{"cvss_score":9,"headline":"Code injection in n/a","id":"CVE-2007-3280","kev_date_added":null,"published":"2007-06-19"},{"cvss_score":8.8,"headline":"PostgreSQL tsvector and tsquery undersize allocations, via integer wraparound","id":"CVE-2026-14662","kev_date_added":null,"published":"2026-08-13"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-14","vendors":["n/a"]},"summary":"A subscriber table creator can execute arbitrary SQL with publication-side credentials via logical replication refresh, requiring an upgrade to fix.","url":"https://insights.sbomify.com/CVE-2026-6638/"}