# CVE-2026-6638: PostgreSQL REFRESH PUBLICATION allows SQL injection via table name

> A subscriber table creator can execute arbitrary SQL with publication-side credentials via logical replication refresh, requiring an upgrade to fix.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 May 2026
- **Updated:** 14 May 2026
- **Also known as:** ALPINE-CVE-2026-6638, AZL-86825, BELL-CVE-2026-6638, BIT-postgresql-2026-6638, DEBIAN-CVE-2026-6638, ECHO-1169-1a51-1552, GHSA-3835-x2rj-c3qj, JLSEC-2026-608, MINI-hcgf-phhv-r383, MINI-jqw5-vw8q-6x78, MINI-xvh9-2q44-jxxx, UBUNTU-CVE-2026-6638

## What is CVE-2026-6638?

CVE-2026-6638 is a low-severity SQL injection vulnerability in Postgresql Postgresql, published on 14 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

SQL injection in PostgreSQL logical replication ALTER SUBSCRIPTION ... REFRESH PUBLICATION allows a subscriber table creator to execute arbitrary SQL with the subscription's publication-side credentials.  The attack takes effect at the next REFRESH PUBLICATION.  Within major versions 16, 17, and 18, minor versions before PostgreSQL 18.4, 17.10, and 16.14 are affected.  Versions before PostgreSQL 16 are unaffected.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-6638?

1 open source package ship an affected version, including postgresql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postgresql` | Bitnami | From 16.0.0 | 16.14.0, 17.10.0, 18.4.0 |

Products: Postgresql Postgresql.

## How do I fix CVE-2026-6638?

Upgrade postgresql to a fixed version for your release line: 16.14.0, 17.10.0 or 18.4.0.

## Is CVE-2026-6638 being exploited?

There is no known exploitation of CVE-2026-6638 in the wild and no public exploit code.

## Other vulnerabilities in Postgresql Postgresql

- [CVE-2013-1902](https://insights.sbomify.com/CVE-2013-1902/): Information disclosure in n/a (critical 10.0)
- [CVE-2013-1903](https://insights.sbomify.com/CVE-2013-1903/): Information disclosure in n/a (critical 10.0)
- [CVE-2007-3279](https://insights.sbomify.com/CVE-2007-3279/): Privilege escalation in n/a (critical 10.0)
- [CVE-2002-1399](https://insights.sbomify.com/CVE-2002-1399/): Integer overflow in n/a (critical 10.0)
- [CVE-2016-3065](https://insights.sbomify.com/CVE-2016-3065/): Information disclosure in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6638 and fix it if it is affected.

What it is: CVE-2026-6638 is a low-severity SQL injection vulnerability in Postgresql Postgresql, published on 14 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-6638 in the wild and no public exploit code.

Affected packages and fixed versions:
- postgresql (Bitnami): affected from 16.0.0; fixed in 16.14.0, 17.10.0, 18.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6638/ (Markdown: https://insights.sbomify.com/CVE-2026-6638/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6638
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6638
- OSV: https://osv.dev/vulnerability/CVE-2026-6638

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6638/
Summaries are generated and may contain mistakes; the official description above is the record.
