CVE-2026-66422 Apache Tomcat: Servlet role references can bypass declarative role constraints

High 8.1 Published Updated

Attackers can bypass declarative role constraints in Apache Tomcat by exploiting improper handling of security-role-ref definitions, gaining unauthorized access.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-66422?

CVE-2026-66422 is a high-severity missing authorization vulnerability in Apache Tomcat, published on 25 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Improper Authorization vulnerability in Apache Tomcat cause by security-role-ref definitions being incorrectly used as role aliases within the Realm in additional to the correct usage with Request.isUserInRole().

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.25 through 9.0.120.

The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.46 through 8.5.100, from 7.0.97 through 7.0.109. Other unsupported versions may also be affected.

Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.

Weakness: CWE-285

Which versions are affected by CVE-2026-66422?

1 open source package ship an affected version, including tomcat. It affects 1 product.

PackageAffectedFixed in
tomcat BitnamiFrom 7.0.979.0.121, 10.1.58, 11.0.25

Products include Apache Tomcat.

How do I fix CVE-2026-66422?

Upgrade tomcat to a fixed version for your release line: 9.0.121, 10.1.58 or 11.0.25.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-66422 being exploited?

There is no known exploitation of CVE-2026-66422 in the wild and no public exploit code.

All Apache Tomcat vulnerabilities

Sources

Also known as BIT-tomcat-2026-66422, DEBIAN-CVE-2026-66422, GHSA-w3xg-786f-g788, MINI-4qph-4xgc-cf9h, MINI-hv9x-wfmc-wwx4, MINI-w3h8-739q-j6mh and 1 more.

Is CVE-2026-66422 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free