{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-6658 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2026-6658 is a medium-severity cross-site scripting vulnerability in jupyter/jupyter, published on 26 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-6658 and fix it if it is affected.\n\nWhat it is: CVE-2026-6658 is a medium-severity cross-site scripting vulnerability in jupyter/jupyter, published on 26 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-6658 exists.\n\nAffected product: jupyter/jupyter. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-6658/ (Markdown: https://insights.sbomify.com/CVE-2026-6658/index.md)","id":"CVE-2026-6658","markdown":"https://insights.sbomify.com/CVE-2026-6658/index.md","name":"CVE-2026-6658","record":{"aliases":["DEBIAN-CVE-2026-6658","GHSA-9754-6rhw-gj3h","UBUNTU-CVE-2026-6658","openSUSE-SU-2026:11725-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Jupyter nbconvert library","requires_auth":"low_privilege","summary":"Attackers can inject arbitrary JavaScript into HTML exports via unsanitized Mermaid output, executing code in the viewer's browser context.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability in jupyter/nbconvert versions \u003c= 7.17.0 allows for Cross-site Scripting (XSS) via unsanitized `text/vnd.mermaid` output in HTML exports. The `data_mermaid` block in `share/templates/lab/base.html.j2` renders `text/vnd.mermaid` cell output directly into HTML without escaping, enabling attackers to inject arbitrary HTML/JavaScript by breaking out of the `\u003cpre\u003e` tag. This vulnerability impacts any server using nbconvert to render notebooks as HTML, allowing attackers to execute arbitrary JavaScript in the context of users viewing the HTML export.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Cross-site Scripting (XSS) in jupyter/nbconvert","id":"CVE-2026-6658","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Crypt::PasswdMD5 versions through 1.42 for Perl generates insecure random values for salts","id":"CVE-2026-6659"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["7.17.1-2.1"],"introduced":["0"],"last_affected":[],"package":"python-nbconvert","purl":"pkg:rpm/opensuse/python-nbconvert\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:11725-1"}],"prev":{"headline":"CORS Origin Validation Bypass in jupyter-server","id":"CVE-2026-6657"},"products":["jupyter/jupyter"],"published":"2026-06-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-26","vendors":["jupyter"]},"summary":"Attackers can inject arbitrary JavaScript into HTML exports via unsanitized Mermaid output, executing code in the viewer's browser context.","url":"https://insights.sbomify.com/CVE-2026-6658/"}