{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-6659 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-6659 is a high-severity vulnerability in RSAVAGE Crypt::PasswdMD5, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-6659 and fix it if it is affected.\n\nWhat it is: CVE-2026-6659 is a high-severity vulnerability in RSAVAGE Crypt::PasswdMD5, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-6659 in the wild and no public exploit code.\n\nAffected product: RSAVAGE Crypt::PasswdMD5. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-6659/ (Markdown: https://insights.sbomify.com/CVE-2026-6659/index.md)","id":"CVE-2026-6659","markdown":"https://insights.sbomify.com/CVE-2026-6659/index.md","name":"CVE-2026-6659","record":{"aliases":["AZL-86411","DEBIAN-CVE-2026-6659","GHSA-j539-xxc6-73wf","UBUNTU-CVE-2026-6659","openSUSE-SU-2026:11000-1","openSUSE-SU-2026:21137-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Perl password hashing library","requires_auth":"none","summary":"Attackers can predict password salts due to insecure random generation, potentially facilitating password cracking attacks against systems using this Perl library.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"CPANSec","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-338","name":"Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG)"}],"description":"Crypt::PasswdMD5 versions through 1.42 for Perl generates insecure random values for salts.\n\nThe built-in rand function is predictable, and unsuitable for cryptography.","ecosystems":["openSUSE:Leap 16.0","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Crypt::PasswdMD5 versions through 1.42 for Perl generates insecure random values for salts","id":"CVE-2026-6659","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"weak_cryptography","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"ericc-ch copilot-api Token Endpoint server.ts cors cross-domain policy","id":"CVE-2026-6662"},"packages":[{"ecosystem":"openSUSE:Leap 16.0","fixed":["1.430.0-bp160.1.1"],"introduced":["0"],"last_affected":[],"package":"perl-Crypt-PasswdMD5","purl":"pkg:rpm/opensuse/perl-Crypt-PasswdMD5\u0026distro=openSUSE%20Leap%2016.0","source":"openSUSE-SU-2026:21137-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.430.0-1.1"],"introduced":["0"],"last_affected":[],"package":"perl-Crypt-PasswdMD5","purl":"pkg:rpm/opensuse/perl-Crypt-PasswdMD5\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:11000-1"}],"prev":{"headline":"Cross-site Scripting (XSS) in jupyter/nbconvert","id":"CVE-2026-6658"},"products":["Crypt::PasswdMD5"],"published":"2026-05-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-26","vendors":["RSAVAGE"]},"summary":"Attackers can predict password salts due to insecure random generation, potentially facilitating password cracking attacks against systems using this Perl library.","url":"https://insights.sbomify.com/CVE-2026-6659/"}