# CVE-2026-6664: PgBouncer integer overflow in PgBouncer network packet parsing

> An unauthenticated remote attacker can crash PgBouncer by sending a malformed SCRAM authentication packet due to an integer overflow in packet parsing.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 May 2026
- **Updated:** 11 May 2026
- **Also known as:** AZL-86234, BIT-pgbouncer-2026-6664, CLEANSTART-2026-AK83492, DEBIAN-CVE-2026-6664, GHSA-pmgp-q838-fh9g, MINI-wphc-9f2g-98fw, UBUNTU-CVE-2026-6664

## What is CVE-2026-6664?

CVE-2026-6664 is a high-severity vulnerability in PgBouncer, published on 9 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An integer overflow in network packet parsing code in PgBouncer before 1.25.2 bypasses a boundary check and can lead to a crash. An unauthenticated remote attacker can crash PgBouncer with a malformed SCRAM authentication packet.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2026-6664?

1 open source package ship an affected version, including pgbouncer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pgbouncer` | Bitnami | All versions | 1.25.2 |

Products: Pgbouncer Pgbouncer.

## How do I fix CVE-2026-6664?

Upgrade pgbouncer to 1.25.2 or later.

## Is CVE-2026-6664 being exploited?

There is no known exploitation of CVE-2026-6664 in the wild and no public exploit code.

Public exploit code:

- Working POC of CVE-2026-6664 written by Sonnet 4.6 (github_poc): https://github.com/nicolasjulian/bouncer-overflow

## Other vulnerabilities in PgBouncer

- [CVE-2026-6665](https://insights.sbomify.com/CVE-2026-6665/): PgBouncer buffer overflow in SCRAM (high 8.1)
- [CVE-2015-6817](https://insights.sbomify.com/CVE-2015-6817/): Auth bypass in n/a (high 8.1)
- [CVE-2025-12819](https://insights.sbomify.com/CVE-2025-12819/): Untrusted search path in auth_query connection in PgBouncer (high 7.5)
- [CVE-2015-4054](https://insights.sbomify.com/CVE-2015-4054/): Null dereference in n/a (high 7.5)
- [CVE-2026-6666](https://insights.sbomify.com/CVE-2026-6666/): PgBouncer crash in kill_pool_logins_server_error (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6664 and fix it if it is affected.

What it is: CVE-2026-6664 is a high-severity vulnerability in PgBouncer, published on 9 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-6664 in the wild and no public exploit code.

Affected packages and fixed versions:
- pgbouncer (Bitnami): affected all versions; fixed in 1.25.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6664/ (Markdown: https://insights.sbomify.com/CVE-2026-6664/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6664
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6664
- OSV: https://osv.dev/vulnerability/CVE-2026-6664

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6664/
Summaries are generated and may contain mistakes; the official description above is the record.
