{"answers":{"affected":"1 open source package ship an affected version, including pgbouncer. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-6667 in the wild and no public exploit code.","fix":"Upgrade pgbouncer to 1.25.2 or later.","what":"CVE-2026-6667 is a medium-severity missing authorization vulnerability in PgBouncer, published on 9 May 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-6667 and fix it if it is affected.\n\nWhat it is: CVE-2026-6667 is a medium-severity missing authorization vulnerability in PgBouncer, published on 9 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-6667 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pgbouncer (Bitnami): affected all versions; fixed in 1.25.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-6667/ (Markdown: https://insights.sbomify.com/CVE-2026-6667/index.md)","id":"CVE-2026-6667","markdown":"https://insights.sbomify.com/CVE-2026-6667/index.md","name":"CVE-2026-6667","record":{"aliases":["AZL-86240","BIT-pgbouncer-2026-6667","CLEANSTART-2026-KP55848","DEBIAN-CVE-2026-6667","GHSA-gc77-jrv9-6fjp","MINI-cr3h-9hgx-hr78","UBUNTU-CVE-2026-6667"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PgBouncer connection pooler","requires_auth":"low_privilege","summary":"Attackers with admin console access can disconnect arbitrary clients via the KILL_CLIENT command, causing denial of service.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"PostgreSQL","cpe":[{"product":"pgbouncer","vendor":"pgbouncer"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"PgBouncer before 1.25.2 did not perform an appropriate authorization check for the KILL_CLIENT admin command. All users with access to the administration console (which itself requires authorization) could run this command. It would have been correct to allow only users listed in the admin_users parameter.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PgBouncer missing authorization check in KILL_CLIENT admin command","id":"CVE-2026-6667","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Integer overflow causes an infinite loop in packet buffer growth in PgBouncer","id":"CVE-2026-6668"},"packages":[{"ecosystem":"Bitnami","fixed":["1.25.2"],"introduced":["0"],"last_affected":[],"package":"pgbouncer","purl":"pkg:bitnami/pgbouncer","source":"BIT-pgbouncer-2026-6667"}],"prev":{"headline":"PgBouncer crash in kill_pool_logins_server_error","id":"CVE-2026-6666"},"products":["PgBouncer"],"published":"2026-05-09","related":[{"cvss_score":8.1,"headline":"PgBouncer buffer overflow in SCRAM","id":"CVE-2026-6665","kev_date_added":null,"published":"2026-05-09"},{"cvss_score":8.1,"headline":"Auth bypass in n/a","id":"CVE-2015-6817","kev_date_added":null,"published":"2017-05-23"},{"cvss_score":7.5,"headline":"PgBouncer integer overflow in PgBouncer network packet parsing","id":"CVE-2026-6664","kev_date_added":null,"published":"2026-05-09"},{"cvss_score":7.5,"headline":"Untrusted search path in auth_query connection in PgBouncer","id":"CVE-2025-12819","kev_date_added":null,"published":"2025-12-03"},{"cvss_score":7.5,"headline":"Null dereference in n/a","id":"CVE-2015-4054","kev_date_added":null,"published":"2017-05-23"},{"cvss_score":5.9,"headline":"PgBouncer crash in kill_pool_logins_server_error","id":"CVE-2026-6666","kev_date_added":null,"published":"2026-05-09"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-11","vendors":["n/a"]},"summary":"Attackers with admin console access can disconnect arbitrary clients via the KILL_CLIENT command, causing denial of service.","url":"https://insights.sbomify.com/CVE-2026-6667/"}