{"answers":{"affected":"1 open source package ship an affected version, including pgbouncer.","exploited":"There is no known exploitation of CVE-2026-6668 in the wild and no public exploit code.","fix":"Upgrade pgbouncer to 1.26.0 or later.","what":"CVE-2026-6668 is a high-severity vulnerability in PgBouncer, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-6668 and fix it if it is affected.\n\nWhat it is: CVE-2026-6668 is a high-severity vulnerability in PgBouncer, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-6668 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pgbouncer (Bitnami): affected all versions; fixed in 1.26.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-6668/ (Markdown: https://insights.sbomify.com/CVE-2026-6668/index.md)","id":"CVE-2026-6668","markdown":"https://insights.sbomify.com/CVE-2026-6668/index.md","name":"CVE-2026-6668","record":{"aliases":["AZL-103433","BIT-pgbouncer-2026-6668","DEBIAN-CVE-2026-6668","ECHO-0782-8daa-3154","GHSA-r96c-7w9v-wrc8","MINI-jh3j-mqmq-w2wv","UBUNTU-CVE-2026-6668"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PgBouncer connection pooler","requires_auth":"none","summary":"An integer overflow in PgBouncer allows remote attackers to cause a denial of service by triggering an infinite loop in packet buffer growth.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"PostgreSQL","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-835","name":"Loop with Unreachable Exit Condition"},{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"Integer overflow in the packet buffer growth logic in PgBouncer through 1.25.2 allows an unauthenticated remote attacker to cause a denial of service. Sufficiently large input makes the buffer size computation overflow, leaving the growth loop unable to terminate. Because PgBouncer serves all clients from a single process, this saturates a CPU core and stalls every pooled connection until the process is killed. Both unauthenticated and authenticated code paths can reach the overflow.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Integer overflow causes an infinite loop in packet buffer growth in PgBouncer","id":"CVE-2026-6668","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"integer_overflow","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Unbounded SCRAM iteration count causes CPU exhaustion in PgBouncer","id":"CVE-2026-6669"},"packages":[{"ecosystem":"Bitnami","fixed":["1.26.0"],"introduced":["0"],"last_affected":[],"package":"pgbouncer","purl":"pkg:bitnami/pgbouncer","source":"BIT-pgbouncer-2026-6668"}],"prev":{"headline":"PgBouncer missing authorization check in KILL_CLIENT admin command","id":"CVE-2026-6667"},"products":["PgBouncer"],"published":"2026-09-23","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-23","vendors":["n/a"]},"summary":"An integer overflow in PgBouncer allows remote attackers to cause a denial of service by triggering an infinite loop in packet buffer growth.","url":"https://insights.sbomify.com/CVE-2026-6668/"}