# CVE-2026-6668: Integer overflow causes an infinite loop in packet buffer growth in PgBouncer

> An integer overflow in PgBouncer allows remote attackers to cause a denial of service by triggering an infinite loop in packet buffer growth.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Sep 2026
- **Updated:** 23 Sep 2026
- **Also known as:** AZL-103433, BIT-pgbouncer-2026-6668, DEBIAN-CVE-2026-6668, ECHO-0782-8daa-3154, GHSA-r96c-7w9v-wrc8, MINI-jh3j-mqmq-w2wv, UBUNTU-CVE-2026-6668

## What is CVE-2026-6668?

CVE-2026-6668 is a high-severity vulnerability in PgBouncer, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Integer overflow in the packet buffer growth logic in PgBouncer through 1.25.2 allows an unauthenticated remote attacker to cause a denial of service. Sufficiently large input makes the buffer size computation overflow, leaving the growth loop unable to terminate. Because PgBouncer serves all clients from a single process, this saturates a CPU core and stalls every pooled connection until the process is killed. Both unauthenticated and authenticated code paths can reach the overflow.

Weakness: CWE-835 (Loop with Unreachable Exit Condition), CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2026-6668?

1 open source package ship an affected version, including pgbouncer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pgbouncer` | Bitnami | All versions | 1.26.0 |

## How do I fix CVE-2026-6668?

Upgrade pgbouncer to 1.26.0 or later.

## Is CVE-2026-6668 being exploited?

There is no known exploitation of CVE-2026-6668 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6668 and fix it if it is affected.

What it is: CVE-2026-6668 is a high-severity vulnerability in PgBouncer, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-6668 in the wild and no public exploit code.

Affected packages and fixed versions:
- pgbouncer (Bitnami): affected all versions; fixed in 1.26.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6668/ (Markdown: https://insights.sbomify.com/CVE-2026-6668/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6668
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6668
- OSV: https://osv.dev/vulnerability/CVE-2026-6668

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6668/
Summaries are generated and may contain mistakes; the official description above is the record.
