{"answers":{"affected":"1 open source package ship an affected version, including pgbouncer.","exploited":"There is no known exploitation of CVE-2026-6669 in the wild and no public exploit code.","fix":"Upgrade pgbouncer to 1.26.0 or later.","what":"CVE-2026-6669 is a medium-severity denial of service vulnerability in PgBouncer, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-6669 and fix it if it is affected.\n\nWhat it is: CVE-2026-6669 is a medium-severity denial of service vulnerability in PgBouncer, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-6669 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pgbouncer (Bitnami): affected all versions; fixed in 1.26.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-6669/ (Markdown: https://insights.sbomify.com/CVE-2026-6669/index.md)","id":"CVE-2026-6669","markdown":"https://insights.sbomify.com/CVE-2026-6669/index.md","name":"CVE-2026-6669","record":{"aliases":["AZL-105063","BIT-pgbouncer-2026-6669","DEBIAN-CVE-2026-6669","ECHO-001a-32d5-11bc","GHSA-58j7-v2vx-r29w","MINI-hvw2-c96x-c9r9","UBUNTU-CVE-2026-6669"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PostgreSQL connection pooler","requires_auth":"none","summary":"A malicious PostgreSQL backend can cause CPU exhaustion in PgBouncer by sending an unbounded SCRAM iteration count, disrupting service for all clients.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"PostgreSQL","cpe":[],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"Missing upper bound on the key derivation iteration count accepted during SCRAM authentication to a backend server in PgBouncer through 1.25.2 allows a malicious or compromised PostgreSQL backend to cause uncontrolled CPU consumption in PgBouncer. The resulting key derivation cannot be interrupted in frontend builds such as PgBouncer. Because PgBouncer serves all clients from a single process, one backend can in this way stop it from serving traffic for every other database and client it is pooling, so the failure of a single backend is not contained.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Unbounded SCRAM iteration count causes CPU exhaustion in PgBouncer","id":"CVE-2026-6669","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Media Sync \u003c= 1.4.9 - Authenticated (Author+) Path Traversal via 'sub_dir' and 'media_items' Parameters","id":"CVE-2026-6670"},"packages":[{"ecosystem":"Bitnami","fixed":["1.26.0"],"introduced":["0"],"last_affected":[],"package":"pgbouncer","purl":"pkg:bitnami/pgbouncer","source":"BIT-pgbouncer-2026-6669"}],"prev":{"headline":"Integer overflow causes an infinite loop in packet buffer growth in PgBouncer","id":"CVE-2026-6668"},"products":["PgBouncer"],"published":"2026-09-23","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-23","vendors":["n/a"]},"summary":"A malicious PostgreSQL backend can cause CPU exhaustion in PgBouncer by sending an unbounded SCRAM iteration count, disrupting service for all clients.","url":"https://insights.sbomify.com/CVE-2026-6669/"}