# CVE-2026-66723: Missing authentication requirement in Remote Instances proxy API in MWDB Core


- **Severity:** High 7.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 29 Jul 2026
- **Updated:** 29 Jul 2026
- **Also known as:** GHSA-942c-r7qj-w895

## What is CVE-2026-66723?

CVE-2026-66723 is a high-severity vulnerability in CERT.PL MWDB Core, published on 29 Jul 2026. 

### Official description

MWDB Core versions >=2.2.0 and <2.19.0 contain a missing authorization vulnerability in the Remote Instances proxy API. The proxy API does not verify authentication for incoming requests, allowing an unauthenticated remote attacker to send arbitrary requests to a remote MWDB instance using the identity and permissions associated with the configured API key. This can result in unauthorized actions being performed on the remote instance as if executed by the user whose API key was used to set up the remote instance. The vulnerability is limited to deployments where Remote Instances have been configured.This issue has been fixed in version 2.19.0

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-66723?


## How do I fix CVE-2026-66723?

No fix has been published for CVE-2026-66723 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-66723 being exploited?

There is no known exploitation of CVE-2026-66723 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-66723 and fix it if it is affected.

What it is: CVE-2026-66723 is a high-severity vulnerability in CERT.PL MWDB Core, published on 29 Jul 2026. 
Exploitation: There is no known exploitation of CVE-2026-66723 in the wild and no public exploit code.

Affected product: CERT.PL MWDB Core. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-66723/ (Markdown: https://insights.sbomify.com/CVE-2026-66723/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-66723
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-66723
- OSV: https://osv.dev/vulnerability/CVE-2026-66723

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-66723/
Summaries are generated and may contain mistakes; the official description above is the record.
