CVE-2026-6681 PKCS#7 decode ignores caller output buffer size, writing past buffer bounds

Low 1.0 Published Updated

An attacker can trigger a buffer overflow in wolfSSL's PKCS#7 decoder by ignoring output buffer size limits, potentially leading to code execution or crashes.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-6681?

CVE-2026-6681 is a low-severity memory corruption vulnerability in Wolfssl Wolfssl, published on 25 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

The PKCS#7 decode path ignores the caller-supplied output buffer size (outputSz), allowing decoded content to be written past the bounds of the provided buffer. This affects wolfSSL 5.9.0 and earlier and was fixed in the 5.9.1 release.

Weakness: CWE-787, CWE-120

Which versions are affected by CVE-2026-6681?

It affects 1 product.

Products include Wolfssl Wolfssl.

How do I fix CVE-2026-6681?

Upgrade to a fixed version.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2026-6681 being exploited?

There is no known exploitation of CVE-2026-6681 in the wild and no public exploit code.

All Wolfssl Wolfssl vulnerabilities

Sources

Also known as DEBIAN-CVE-2026-6681, GHSA-6q89-vxvr-wgv2, JLSEC-2026-754, UBUNTU-CVE-2026-6681.

Is CVE-2026-6681 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free