# CVE-2026-6681: PKCS#7 decode ignores caller output buffer size, writing past buffer bounds

> An attacker can trigger a buffer overflow in wolfSSL's PKCS#7 decoder by ignoring output buffer size limits, potentially leading to code execution or crashes.

- **Severity:** Low 1.0 (`CVSS:4.0/AV:A/AC:L/AT:P/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/U:Clear`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Jun 2026
- **Updated:** 26 Jun 2026
- **Also known as:** DEBIAN-CVE-2026-6681, GHSA-6q89-vxvr-wgv2, JLSEC-2026-754, UBUNTU-CVE-2026-6681

## What is CVE-2026-6681?

CVE-2026-6681 is a low-severity memory corruption vulnerability in Wolfssl Wolfssl, published on 25 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

The PKCS#7 decode path ignores the caller-supplied output buffer size (outputSz), allowing decoded content to be written past the bounds of the provided buffer. This affects wolfSSL 5.9.0 and earlier and was fixed in the 5.9.1 release.

Weakness: CWE-787 (Out-of-bounds Write), CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2026-6681?

It affects 1 product.


Products: Wolfssl Wolfssl.

## How do I fix CVE-2026-6681?

Upgrade to a fixed version.

## Is CVE-2026-6681 being exploited?

There is no known exploitation of CVE-2026-6681 in the wild and no public exploit code.

## Other vulnerabilities in Wolfssl Wolfssl

- [CVE-2024-5991](https://insights.sbomify.com/CVE-2024-5991/): Buffer overread in domain name matching (critical 10.0)
- [CVE-2021-37155](https://insights.sbomify.com/CVE-2021-37155/): Security feature bypass in n/a (critical 9.8)
- [CVE-2020-36177](https://insights.sbomify.com/CVE-2020-36177/): Memory corruption in n/a (critical 9.8)
- [CVE-2014-2896](https://insights.sbomify.com/CVE-2014-2896/): Memory corruption in n/a (critical 9.8)
- [CVE-2014-2897](https://insights.sbomify.com/CVE-2014-2897/): Memory corruption in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6681 and fix it if it is affected.

What it is: CVE-2026-6681 is a low-severity memory corruption vulnerability in Wolfssl Wolfssl, published on 25 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-6681 in the wild and no public exploit code.

Affected product: Wolfssl Wolfssl. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6681/ (Markdown: https://insights.sbomify.com/CVE-2026-6681/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6681
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6681
- OSV: https://osv.dev/vulnerability/CVE-2026-6681

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6681/
Summaries are generated and may contain mistakes; the official description above is the record.
