# CVE-2026-66829: html_sanitize_ex HTML5 scrubber keeps attacker-supplied meta refresh, allowing forced cross-origin redirection

> Attackers can force users to redirect to malicious sites via meta refresh tags in sanitized HTML, requiring an upgrade to the html_sanitize_ex library.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Aug 2026
- **Updated:** 19 Aug 2026
- **Also known as:** EEF-CVE-2026-66829, GHSA-2c6f-3j54-xpcr, GHSA-c486-5fvq-fp3v

## What is CVE-2026-66829?

CVE-2026-66829 is a low-severity vulnerability in rrrene html_sanitize_ex, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

URL Redirection to Untrusted Site ('Open Redirect') vulnerability in the HTML5 scrubber in rrrene html_sanitize_ex allows a remote attacker to force visitors of a page to navigate to a site of the attacker's choosing via a <meta http-equiv="refresh"> element in sanitized HTML. HtmlSanitizeEx.html5/1 keeps attacker-supplied <meta> elements in its output. A meta element acts on the whole document rather than on the fragment it was embedded in, so it can also declare document-wide directives such as Content-Security-Policy.

This is not cross-site scripting. Browsers do not navigate a meta refresh to a javascript: URL, so the uppercase JAVASCRIPT: filter bypass yields no script execution and none was demonstrated.

This issue affects html_sanitize_ex: from 0.3.1 before 1.4.5 and from 1.5.0-rc.0 before 1.5.3.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2026-66829?

1 open source package ship an affected version, including html_sanitize_ex. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `html_sanitize_ex` | Hex | From 0.3.1 | 1.4.5, 1.5.3 |

Products: Rrrene Htmlsanitizeex.

## How do I fix CVE-2026-66829?

Upgrade html_sanitize_ex to a fixed version for your release line: 1.4.5 or 1.5.3.

## Is CVE-2026-66829 being exploited?

There is no known exploitation of CVE-2026-66829 in the wild and no public exploit code.

## Other vulnerabilities in rrrene html_sanitize_ex

- [CVE-2026-68749](https://insights.sbomify.com/CVE-2026-68749/): Quadratic regex backtracking in the html_sanitize_ex CSS scrubber allows CPU-exhaustion denial of service (high 8.2)
- [CVE-2026-68750](https://insights.sbomify.com/CVE-2026-68750/): Quadratic sibling re-flattening in the html_sanitize_ex traversal engine allows CPU-exhaustion denial of service (high 8.2)
- [CVE-2026-66370](https://insights.sbomify.com/CVE-2026-66370/): html_sanitize_ex HTML5 scrubber keeps attacker-supplied form-association attributes, allowing form hijacking (medium 4.8)
- [CVE-2026-66843](https://insights.sbomify.com/CVE-2026-66843/): html_sanitize_ex HTML5 scrubber keeps attacker-supplied `<object>` elements, allowing untrusted content embedding (low 2.3)
- [CVE-2026-68747](https://insights.sbomify.com/CVE-2026-68747/): CSS sanitizer allowlist bypass in html_sanitize_ex via non-declaration input (low 2.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-66829 and fix it if it is affected.

What it is: CVE-2026-66829 is a low-severity vulnerability in rrrene html_sanitize_ex, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-66829 in the wild and no public exploit code.

Affected packages and fixed versions:
- html_sanitize_ex (Hex): affected from 0.3.1; fixed in 1.4.5, 1.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-66829/ (Markdown: https://insights.sbomify.com/CVE-2026-66829/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-66829
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-66829
- OSV: https://osv.dev/vulnerability/CVE-2026-66829

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-66829/
Summaries are generated and may contain mistakes; the official description above is the record.
