# CVE-2026-66838: SQL injection via the :comment option in Postgrex.stream/4

> Attackers can inject SQL commands via the comment option in Postgrex.stream/4, allowing execution of arbitrary clauses under the database connection's role.

- **Severity:** Medium 5.9 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Aug 2026
- **Updated:** 7 Aug 2026
- **Also known as:** EEF-CVE-2026-66838, GHSA-3gww-3f36-2388

## What is CVE-2026-66838?

CVE-2026-66838 is a medium-severity SQL injection vulnerability in elixir-ecto postgrex, published on 7 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in elixir-ecto postgrex allows SQL Injection via the :comment option of Postgrex.stream/4. An attacker who can influence that value can close the comment delimiter with */ and extend the streamed statement with their own clauses, which execute under the connection's role. Ecto exposes the same option through Ecto.Repo.stream/2.

Postgrex appends the comment by concatenating it into the statement text sent in the Parse message, without escaping or rejecting */. The option is validated by comment_not_present!/1 at every other execution point; stream/4 never calls it. Because Parse accepts a single command, the injection is confined to the streamed statement and further statements cannot be chained.

This issue affects postgrex: from 0.19.3 before 0.22.4.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-66838?

1 open source package ship an affected version, including postgrex. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postgrex` | Hex | From 0.19.3 | 0.22.4 |

Products: Elixir-Ecto Postgrex.

## How do I fix CVE-2026-66838?

Upgrade postgrex to 0.22.4 or later.

## Is CVE-2026-66838 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-66838 exists.

## Other vulnerabilities in elixir-ecto postgrex

- [CVE-2026-32687](https://insights.sbomify.com/CVE-2026-32687/): SQL injection via channel name in Postgrex.Notifications.listen/3 and unlisten/3 (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-66838 and fix it if it is affected.

What it is: CVE-2026-66838 is a medium-severity SQL injection vulnerability in elixir-ecto postgrex, published on 7 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-66838 exists.

Affected packages and fixed versions:
- postgrex (Hex): affected from 0.19.3; fixed in 0.22.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-66838/ (Markdown: https://insights.sbomify.com/CVE-2026-66838/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-66838
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-66838
- OSV: https://osv.dev/vulnerability/CVE-2026-66838

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-66838/
Summaries are generated and may contain mistakes; the official description above is the record.
