# CVE-2026-66843: html_sanitize_ex HTML5 scrubber keeps attacker-supplied `<object>` elements, allowing untrusted content embedding

> Attackers can embed untrusted content via object tags in sanitized HTML, potentially leading to script execution or content injection in trusted pages.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Aug 2026
- **Updated:** 19 Aug 2026
- **Also known as:** EEF-CVE-2026-66843, GHSA-6g7x-33rf-28v3, GHSA-xmm9-jc22-rcgj

## What is CVE-2026-66843?

CVE-2026-66843 is a low-severity cross-site scripting vulnerability in rrrene html_sanitize_ex, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Inclusion of Functionality from Untrusted Control Sphere vulnerability in the HTML5 scrubber in rrrene html_sanitize_ex allows a remote attacker to load a document of their choosing into a trusted page via the data attribute of an <object> element in sanitized HTML. object is the one URI-bearing element in lib/html_sanitize_ex/scrubber/html5.ex never registered through allow_tag_with_uri_attributes/3, and its only guard is a prefix match on lowercase "javascript:", so mixed-case variants, data: URIs, protocol-relative URLs and same-origin paths all survive.

This is not unconditional cross-site scripting. A javascript: URL does not execute through <object data> in current browsers, data: documents load in an opaque origin, and host-origin script execution additionally requires the application to serve attacker-controlled content from a same-origin path.

This issue affects html_sanitize_ex: from 0.3.1 before 1.4.5 and from 1.5.0-rc.0 before 1.5.3.

Weakness: CWE-829 (Inclusion of Functionality from Untrusted Control Sphere)

## Which versions are affected by CVE-2026-66843?

1 open source package ship an affected version, including html_sanitize_ex. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `html_sanitize_ex` | Hex | From 0.3.1 | 1.4.5, 1.5.3 |

Products: Rrrene Htmlsanitizeex.

## How do I fix CVE-2026-66843?

Upgrade html_sanitize_ex to a fixed version for your release line: 1.4.5 or 1.5.3.

## Is CVE-2026-66843 being exploited?

There is no known exploitation of CVE-2026-66843 in the wild and no public exploit code.

## Other vulnerabilities in rrrene html_sanitize_ex

- [CVE-2026-68749](https://insights.sbomify.com/CVE-2026-68749/): Quadratic regex backtracking in the html_sanitize_ex CSS scrubber allows CPU-exhaustion denial of service (high 8.2)
- [CVE-2026-68750](https://insights.sbomify.com/CVE-2026-68750/): Quadratic sibling re-flattening in the html_sanitize_ex traversal engine allows CPU-exhaustion denial of service (high 8.2)
- [CVE-2026-66370](https://insights.sbomify.com/CVE-2026-66370/): html_sanitize_ex HTML5 scrubber keeps attacker-supplied form-association attributes, allowing form hijacking (medium 4.8)
- [CVE-2026-66829](https://insights.sbomify.com/CVE-2026-66829/): html_sanitize_ex HTML5 scrubber keeps attacker-supplied meta refresh, allowing forced cross-origin redirection (low 2.3)
- [CVE-2026-68747](https://insights.sbomify.com/CVE-2026-68747/): CSS sanitizer allowlist bypass in html_sanitize_ex via non-declaration input (low 2.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-66843 and fix it if it is affected.

What it is: CVE-2026-66843 is a low-severity cross-site scripting vulnerability in rrrene html_sanitize_ex, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-66843 in the wild and no public exploit code.

Affected packages and fixed versions:
- html_sanitize_ex (Hex): affected from 0.3.1; fixed in 1.4.5, 1.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-66843/ (Markdown: https://insights.sbomify.com/CVE-2026-66843/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-66843
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-66843
- OSV: https://osv.dev/vulnerability/CVE-2026-66843

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-66843/
Summaries are generated and may contain mistakes; the official description above is the record.
