{"answers":{"affected":"1 open source package ship an affected version, including thrift.","exploited":"There is no known exploitation of CVE-2026-66858 in the wild and no public exploit code.","fix":"Upgrade thrift to 0.25.0 or later.","what":"CVE-2026-66858 is a high-severity denial of service vulnerability in Apache Thrift, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-66858 and fix it if it is affected.\n\nWhat it is: CVE-2026-66858 is a high-severity denial of service vulnerability in Apache Thrift, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-66858 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- thrift (Bitnami): affected all versions; fixed in 0.25.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-66858/ (Markdown: https://insights.sbomify.com/CVE-2026-66858/index.md)","id":"CVE-2026-66858","markdown":"https://insights.sbomify.com/CVE-2026-66858/index.md","name":"CVE-2026-66858","record":{"aliases":["AZL-105950","BIT-thrift-2026-66858","DEBIAN-CVE-2026-66858","ECHO-daeb-c7a3-60a5","GHSA-hfqq-j57v-2292","MINI-pmgq-vfq4-4g83","UBUNTU-CVE-2026-66858"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Thrift library","requires_auth":"none","summary":"Attackers can cause denial of service via stack exhaustion in multiple Apache Thrift language bindings by sending deeply nested unknown fields.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"The protocol skip routine in several Apache Thrift bindings did not apply the binding's recursion limit, so a message that nests unknown fields deeply enough can exhaust the stack. Affected: the Python C++ accelerator (the pure-Python protocols are not affected), the PHP library and its thrift_protocol extension, and the Perl, Lua, Smalltalk and OCaml libraries.\n\nThis issue affects Apache Thrift: before 0.25.0.\n\nUsers are recommended to upgrade to version 0.25.0, which fixes the issue.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in Apache Thrift","id":"CVE-2026-66858","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":1,"n_references":2,"next":{"headline":"Apache Thrift: c_glib multiplexed processor crashes on a message it cannot route","id":"CVE-2026-66859"},"packages":[{"ecosystem":"Bitnami","fixed":["0.25.0"],"introduced":["0"],"last_affected":[],"package":"thrift","purl":"pkg:bitnami/thrift","source":"BIT-thrift-2026-66858"}],"prev":{"headline":"Gitea restricted-user organization metadata disclosure","id":"CVE-2026-66853"},"products":["Apache Thrift"],"published":"2026-10-02","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-02","vendors":["Apache Software Foundation"]},"summary":"Attackers can cause denial of service via stack exhaustion in multiple Apache Thrift language bindings by sending deeply nested unknown fields.","url":"https://insights.sbomify.com/CVE-2026-66858/"}