# CVE-2026-66858: Denial of service in Apache Thrift

> Attackers can cause denial of service via stack exhaustion in multiple Apache Thrift language bindings by sending deeply nested unknown fields.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Oct 2026
- **Updated:** 2 Oct 2026
- **Also known as:** AZL-105950, BIT-thrift-2026-66858, DEBIAN-CVE-2026-66858, ECHO-daeb-c7a3-60a5, GHSA-hfqq-j57v-2292, MINI-pmgq-vfq4-4g83, UBUNTU-CVE-2026-66858

## What is CVE-2026-66858?

CVE-2026-66858 is a high-severity denial of service vulnerability in Apache Thrift, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The protocol skip routine in several Apache Thrift bindings did not apply the binding's recursion limit, so a message that nests unknown fields deeply enough can exhaust the stack. Affected: the Python C++ accelerator (the pure-Python protocols are not affected), the PHP library and its thrift_protocol extension, and the Perl, Lua, Smalltalk and OCaml libraries.

This issue affects Apache Thrift: before 0.25.0.

Users are recommended to upgrade to version 0.25.0, which fixes the issue.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2026-66858?

1 open source package ship an affected version, including thrift.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `thrift` | Bitnami | All versions | 0.25.0 |

## How do I fix CVE-2026-66858?

Upgrade thrift to 0.25.0 or later.

## Is CVE-2026-66858 being exploited?

There is no known exploitation of CVE-2026-66858 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-66858 and fix it if it is affected.

What it is: CVE-2026-66858 is a high-severity denial of service vulnerability in Apache Thrift, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-66858 in the wild and no public exploit code.

Affected packages and fixed versions:
- thrift (Bitnami): affected all versions; fixed in 0.25.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-66858/ (Markdown: https://insights.sbomify.com/CVE-2026-66858/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-66858
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-66858
- OSV: https://osv.dev/vulnerability/CVE-2026-66858

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-66858/
Summaries are generated and may contain mistakes; the official description above is the record.
