# CVE-2026-66882: Reflected XSS in AshAuthentication confirmation and magic link interaction forms

> Reflected XSS in AshAuthentication allows attackers to execute scripts in the victim's browser via crafted confirmation or magic link URLs, potentially stealing sessions.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** EEF-CVE-2026-66882, GHSA-54fc-x3hv-ffhw

## What is CVE-2026-66882?

CVE-2026-66882 is a low-severity cross-site scripting vulnerability in team-alembic ash_authentication, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Improper Neutralization of Input During Web Page Generation (XSS) vulnerability in team-alembic AshAuthentication allows reflected cross-site scripting via the confirmation and magic link interaction forms.

When a strategy is configured with require_interaction? set to true, AshAuthentication serves an intermediate HTML page asking the user to confirm the action by submitting a form. Both such pages embed a request parameter directly into a hidden input's value attribute without HTML escaping: lib/ash_authentication/add_ons/confirmation/confirmation_form.html.eex interpolates the confirm parameter, and lib/ash_authentication/strategies/magic_link/sign_in_form.html.eex interpolates the magic link token parameter. These templates are compiled with EEx.function_from_file/3 using plain <%= %> expressions, which perform no escaping, so the parameter is reflected verbatim.

Neither accept handler validates the value before rendering it. AshAuthentication.AddOn.Confirmation.Plug.accept/2 only checks that a confirm key is present, and AshAuthentication.Strategy.MagicLink.Plug.accept/2 reads the parameter directly, so no token signature is verified at this stage and arbitrary attacker-supplied text reaches the template. An unauthenticated attacker can therefore craft a URL whose parameter terminates the attribute and injects markup, for example a quote followed by a <script> element. Because the accept phase is served over GET, loading the crafted link is sufficient; no form submission or prior authentication is required.

The injected script executes in the origin of the application embedding AshAuthentication, giving it access to that origin's cookies, session, and same-origin responses. Since these pages are part of the authentication flow, a victim following what appears to be a legitimate confirmation or sign-in link is a plausible target.

This issue affects ash_authentication: from 4.8.0 before 4.14.2 and from 5.0.0-rc.0 before 5.0.0-rc.13.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-66882?

1 open source package ship an affected version, including ash_authentication.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ash_authentication` | Hex | From 4.8.0 | 4.14.2, 5.0.0-rc.13 |

## How do I fix CVE-2026-66882?

Upgrade ash_authentication to a fixed version for your release line: 4.14.2 or 5.0.0-rc.13.

## Is CVE-2026-66882 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-66882 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-66882 and fix it if it is affected.

What it is: CVE-2026-66882 is a low-severity cross-site scripting vulnerability in team-alembic ash_authentication, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-66882 exists.

Affected packages and fixed versions:
- ash_authentication (Hex): affected from 4.8.0; fixed in 4.14.2, 5.0.0-rc.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-66882/ (Markdown: https://insights.sbomify.com/CVE-2026-66882/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-66882
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-66882
- OSV: https://osv.dev/vulnerability/CVE-2026-66882

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-66882/
Summaries are generated and may contain mistakes; the official description above is the record.
