# CVE-2026-6689: Mattermost doesn't enforce PermissionInviteUser when setting AllowOpenInvite or AllowedDomains during team creation

> Authenticated users can bypass permission checks to configure open-invite and domain restrictions during team creation.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2026
- **Updated:** 12 Jun 2026
- **Also known as:** GHSA-c28q-m4gf-vg4q, GO-2026-6283

## What is CVE-2026-6689?

CVE-2026-6689 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 12 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost versions 11.6.x <= 11.6.1, 11.5.x <= 11.5.4, 10.11.x <= 10.11.15, 10.11.x <= 10.11.16 Fail to enforce PermissionInviteUser when setting AllowOpenInvite or AllowedDomains during team creation (the check was only applied on update/patch), which allows an authenticated user holding PermissionCreateTeam but not PermissionInviteUser on the resulting team to configure invite-controlled team settings (make the team publicly joinable via open invite and/or constrain membership via allowed domains) that they are not permitted to set on an existing team via POST /api/v4/teams with allow_open_invite: true and/or a non-empty allowed_domains in the request body.. Mattermost Advisory ID: MMSA-2026-00655

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-6689?

12 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0 | 10.11.17 |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0 | 10.11.17 |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0+incompatible | 10.11.17+incompatible, 11.5.5+incompatible, 11.6.1+incompatible |
| `github.com/mattermost/mattermost-server` | Go | From 11.5.0 | 11.5.5 |
| `github.com/mattermost/mattermost-server` | Go | From 11.5.0 | 11.5.5 |
| `github.com/mattermost/mattermost-server` | Go | From 11.6.0 | 11.6.1 |
| `github.com/mattermost/mattermost-server` | Go | From 11.6.0 | 11.6.1 |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |
| `github.com/mattermost/mattermost/server/v8` | Go | From 8.0.0-20250731163400-5b955468ea1e | 8.0.0-20260501144115-7d6816abdfd1 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 8.0.0-20250731163400-5b955468ea1e | 8.0.0-20260501144115-7d6816abdfd1 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 8.0.0-20250731163400-5b955468ea1e | 8.0.0-20260501144115-7d6816abdfd1 |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2026-6689?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.17, 10.11.17+incompatible, 11.5.5+incompatible or 11.6.1+incompatible.

## Is CVE-2026-6689 being exploited?

There is no known exploitation of CVE-2026-6689 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6689 and fix it if it is affected.

What it is: CVE-2026-6689 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 12 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-6689 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0; fixed in 10.11.17
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0; fixed in 10.11.17
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0+incompatible; fixed in 10.11.17+incompatible, 11.5.5+incompatible, 11.6.1+incompatible
- github.com/mattermost/mattermost-server (Go): affected from 11.5.0; fixed in 11.5.5
- github.com/mattermost/mattermost-server (Go): affected from 11.5.0; fixed in 11.5.5
- github.com/mattermost/mattermost-server (Go): affected from 11.6.0; fixed in 11.6.1
- github.com/mattermost/mattermost-server (Go): affected from 11.6.0; fixed in 11.6.1
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v6 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected from 8.0.0-20250731163400-5b955468ea1e; fixed in 8.0.0-20260501144115-7d6816abdfd1
- github.com/mattermost/mattermost/server/v8 (Go): affected from 8.0.0-20250731163400-5b955468ea1e; fixed in 8.0.0-20260501144115-7d6816abdfd1
- github.com/mattermost/mattermost/server/v8 (Go): affected from 8.0.0-20250731163400-5b955468ea1e; fixed in 8.0.0-20260501144115-7d6816abdfd1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6689/ (Markdown: https://insights.sbomify.com/CVE-2026-6689/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6689
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6689
- OSV: https://osv.dev/vulnerability/CVE-2026-6689

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6689/
Summaries are generated and may contain mistakes; the official description above is the record.
