CVE-2026-67219 RabbitMQ: Consistent-hash exchange unbounded weight
An attacker with binding permissions can cause memory exhaustion and service outage by creating a consistent-hash exchange binding with an excessively large weight.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-67219?
CVE-2026-67219 is a medium-severity denial of service vulnerability in Broadcom Rabbitmq Server, published on 23 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, add_binding/3 parses the routing key as an integer weight N and computes ring positions with lists:seq(NextN0, NextN0 + N - 1). validate_binding/2 only checks N >= 1 , no upper bound. The resulting list is stored in the exchange's Khepri record, replicated cluster-wide, and reloaded on restart. A user with write permission on a consistent-hash exchange and read on a queue can create a binding whose routing key (the hash-ring weight) is an arbitrarily large integer. The broker allocates a list of that many integers via lists:seq/2 and persists it to Khepri across all cluster nodes , a single binding with weight 100000000 allocates ~800 MB on every node and survives restarts. Preconditions include rabbitmq_consistent_hash_exchange plugin enabled write permission on a consistent-hash exchange + read on a queue (standard binding perms). This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0.
Weakness: CWE-770
Which versions are affected by CVE-2026-67219?
1 open source package ship an affected version, including rabbitmq. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
rabbitmq Bitnami | From 3.13.0 | 3.13.15, 4.0.20, 4.1.11, 4.2.6 |
Products include Broadcom Rabbitmq Server.
How do I fix CVE-2026-67219?
Upgrade rabbitmq to a fixed version for your release line: 3.13.15, 4.0.20, 4.1.11 or 4.2.6.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-67219 being exploited?
There is no known exploitation of CVE-2026-67219 in the wild and no public exploit code.
Other vulnerabilities in Broadcom Rabbitmq Server
- CVE-2016-9877 Auth bypass in Pivotal RabbitMQ 3.x before 3.5.8 and 3.6.x before 3.6.6; RabbitMQ for PCF 1.5.x before 1.5.20, 1.6.x before 1.6.12 and 1.7.x before 1.7.7
- CVE-2026-67404 RabbitMQ: OAuth2 silent verify_none fallback for JWKS fetch
- CVE-2026-67231 RabbitMQ: Trust-store whitelist by Issuer+Serial only
- CVE-2026-57219 Information disclosure in rabbitmq-server
- CVE-2026-67236 RabbitMQ: Plaintext username:password stored in an insecure cookie after successful POST /login
Sources
Also known as AZL-105759, BIT-rabbitmq-2026-67219, DEBIAN-CVE-2026-67219, GHSA-m8pg-4x2h-jvgr, UBUNTU-CVE-2026-67219.