# CVE-2026-67223: RabbitMQ: LDAP DN injection via unescaped substitution

> Attackers can inject LDAP DNs via crafted usernames to bypass authentication if specific LDAP patterns are configured.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Sep 2026
- **Updated:** 25 Sep 2026
- **Also known as:** AZL-105305, BIT-rabbitmq-2026-67223, DEBIAN-CVE-2026-67223, GHSA-9x7r-g78c-5835, UBUNTU-CVE-2026-67223

## What is CVE-2026-67223?

CVE-2026-67223 is a medium-severity vulnerability in Broadcom Rabbitmq Server, published on 25 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

RabbitMQ is a messaging and streaming broker. The advisory establishes affected 3.13, 4.0, 4.1, 4.2, and 4.3 maintenance lines but contains conflicting first-fixed versions for the 3.13, 4.0, and 4.1 lines. fill/2 substitutes ${username} into user_dn_pattern without RFC 4514 DN escaping, allowing a crafted username to alter the LDAP bind DN and potentially select a different directory entry. Exploitation requires rabbitmq_auth_backend_ldap with a user_dn_pattern containing ${username}, a directory layout in which the injected suffix resolves usefully, and a password valid for the resulting DN. The advisory body identifies 3.13.15, 4.0.20, 4.1.11, 4.2.9, and 4.3.3 as fixed, while structured metadata identifies 3.13.18, 4.0.23, 4.1.14, 4.2.9, and 4.3.3. No fixed-version assertion is certifiable until a curator resolves this conflict.

Weakness: CWE-90 (Improper Neutralization of Special Elements used in an LDAP Query)

## Which versions are affected by CVE-2026-67223?

1 open source package ship an affected version, including rabbitmq. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rabbitmq` | Bitnami | From 3.13.0 | 3.13.18, 4.0.23, 4.1.14, 4.2.9, 4.3.3 |

Products: Broadcom Rabbitmq Server.

## How do I fix CVE-2026-67223?

Upgrade rabbitmq to a fixed version for your release line: 3.13.18, 4.0.23, 4.1.14 or 4.2.9.

## Is CVE-2026-67223 being exploited?

There is no known exploitation of CVE-2026-67223 in the wild and no public exploit code.

## Other vulnerabilities in Broadcom Rabbitmq Server

- [CVE-2016-9877](https://insights.sbomify.com/CVE-2016-9877/): Auth bypass in Pivotal RabbitMQ 3.x before 3.5.8 and 3.6.x before 3.6.6; RabbitMQ for PCF 1.5.x before 1.5.20, 1.6.x before 1.6.12 and 1.7.x before 1.7.7 (critical 9.8)
- [CVE-2026-67404](https://insights.sbomify.com/CVE-2026-67404/): RabbitMQ: OAuth2 silent verify_none fallback for JWKS fetch (critical 9.2)
- [CVE-2026-67231](https://insights.sbomify.com/CVE-2026-67231/): RabbitMQ: Trust-store whitelist by Issuer+Serial only (critical 9.1)
- [CVE-2026-57219](https://insights.sbomify.com/CVE-2026-57219/): Information disclosure in rabbitmq-server (high 8.7)
- [CVE-2026-67236](https://insights.sbomify.com/CVE-2026-67236/): RabbitMQ: Plaintext username:password stored in an insecure cookie after successful POST /login (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67223 and fix it if it is affected.

What it is: CVE-2026-67223 is a medium-severity vulnerability in Broadcom Rabbitmq Server, published on 25 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-67223 in the wild and no public exploit code.

Affected packages and fixed versions:
- rabbitmq (Bitnami): affected from 3.13.0; fixed in 3.13.18, 4.0.23, 4.1.14, 4.2.9, 4.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67223/ (Markdown: https://insights.sbomify.com/CVE-2026-67223/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67223
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67223
- OSV: https://osv.dev/vulnerability/CVE-2026-67223

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67223/
Summaries are generated and may contain mistakes; the official description above is the record.
