CVE-2026-67227 RabbitMQ: Atom exhaustion: to_atom on global-parameter :name
A user with policymaker tag can crash the RabbitMQ node by exhausting the atom table via repeated API requests when the management plugin is enabled.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-67227?
CVE-2026-67227 is a medium-severity denial of service vulnerability in Broadcom Rabbitmq Server, published on 25 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
RabbitMQ is a messaging and streaming broker. From 4.0.0 until 4.0.22 and 4.1.14 and 4.2.7 and 4.3.1, Atom exhaustion: toatom on global-parameter :name. resourceexists/2 (and the PUT/DELETE handlers) call rabbitdatacoercion:toatom/1 on the :name URL path segment. toatom/1 uses binarytoatom/2 (unsafe). The endpoint requires policymaker (not management, but below A user with the policymaker tag can crash the node by exhausting the atom table via repeated requests to /api/global-parameters/:name with unique :name Management plugin enabled policymaker tag ~1M HTTP. This issue is fixed in versions 4.0.22 and 4.1.14 and 4.2.7 and 4.3.1.
Weakness: CWE-400
Which versions are affected by CVE-2026-67227?
1 open source package ship an affected version, including rabbitmq. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
rabbitmq Bitnami | From 4.0.0 | 4.0.22, 4.1.14, 4.2.7, 4.3.1 |
Products include Broadcom Rabbitmq Server.
How do I fix CVE-2026-67227?
Upgrade rabbitmq to a fixed version for your release line: 4.0.22, 4.1.14, 4.2.7 or 4.3.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-67227 being exploited?
There is no known exploitation of CVE-2026-67227 in the wild and no public exploit code.
Other vulnerabilities in Broadcom Rabbitmq Server
- CVE-2016-9877 Auth bypass in Pivotal RabbitMQ 3.x before 3.5.8 and 3.6.x before 3.6.6; RabbitMQ for PCF 1.5.x before 1.5.20, 1.6.x before 1.6.12 and 1.7.x before 1.7.7
- CVE-2026-67404 RabbitMQ: OAuth2 silent verify_none fallback for JWKS fetch
- CVE-2026-67231 RabbitMQ: Trust-store whitelist by Issuer+Serial only
- CVE-2026-57219 Information disclosure in rabbitmq-server
- CVE-2026-67236 RabbitMQ: Plaintext username:password stored in an insecure cookie after successful POST /login
Sources
Also known as AZL-105293, BIT-rabbitmq-2026-67227, DEBIAN-CVE-2026-67227, GHSA-q7x8-97rh-cr24, UBUNTU-CVE-2026-67227.