CVE-2026-67229 RabbitMQ: Admin-only atom exhaustion: atomize_keys on vhost metadata

Medium 6.9 Published Updated

An administrator can crash the RabbitMQ node by importing a crafted definitions file with excessive metadata keys, exhausting the atom table.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-67229?

CVE-2026-67229 is a medium-severity denial of service vulnerability in Broadcom Rabbitmq Server, published on 23 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, add_vhost/2 calls rabbit_data_coercion:atomize_keys/1 (the unsafe variant using binary_to_atom) on the vhost metadata map. The 20 MB management body limit fits ~1M+ short keys. Admin-only. An administrator importing a crafted definitions file can crash the node in a single request: a vhosts entry with ~1M unique metadata keys exhausts the atom table during import. Preconditions include administrator tag. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0.

Weakness: CWE-400

Which versions are affected by CVE-2026-67229?

1 open source package ship an affected version, including rabbitmq. It affects 1 product.

PackageAffectedFixed in
rabbitmq BitnamiFrom 3.13.03.13.15, 4.0.20, 4.1.11, 4.2.6

Products include Broadcom Rabbitmq Server.

How do I fix CVE-2026-67229?

Upgrade rabbitmq to a fixed version for your release line: 3.13.15, 4.0.20, 4.1.11 or 4.2.6.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-67229 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67229 exists.

All Broadcom Rabbitmq Server vulnerabilities

Sources

Also known as AZL-105804, BIT-rabbitmq-2026-67229, DEBIAN-CVE-2026-67229, GHSA-ggrw-qm45-hwpv, UBUNTU-CVE-2026-67229.

Is CVE-2026-67229 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free