CVE-2026-67231 RabbitMQ: Trust-store whitelist by Issuer+Serial only

Critical 9.1 Published Updated

Attackers can bypass TLS client authentication in RabbitMQ by forging certificates if the trust-store plugin is enabled and issuer/serial details are known.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-67231?

CVE-2026-67231 is a critical authentication bypass vulnerability in Broadcom Rabbitmq Server, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, The trust-store plugin installs a verify_fun that overrides {bad_cert, unknown_ca} / {bad_cert, selfsigned_peer} when the presented cert "matches" a whitelisted one. The match key is extract_issuer_id/1 → public_key:pkix_issuer_id/2 → {IssuerName, SerialNumber} , both fields are taken verbatim from the presented certificate body and contain no public-key, SKI, fingerprint or signature material. is_whitelisted/1 is a pure ets:member lookup; the stored full DER is used only for list/0 display and is never compared against the presented cert. cacerts is [], so the whitelisted cert is never used as a trust anchor for path validation either. TLS client-authentication bypass: an attacker who knows the issuer DN + serial of any whitelisted certificate can connect with a forged self-signed cert. Preconditions include rabbitmq_trust_store plugin enabled and used as the TLS verify_fun Attacker knows or can guess the {Issuer, Serial} of at least one whitelisted cert (non-secret; exposed via CLI/logs/any cert copy). This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0.

Weakness: CWE-295

Which versions are affected by CVE-2026-67231?

1 open source package ship an affected version, including rabbitmq. It affects 1 product.

PackageAffectedFixed in
rabbitmq BitnamiFrom 3.13.03.13.15, 4.0.20, 4.1.11, 4.2.6

Products include Broadcom Rabbitmq Server.

How do I fix CVE-2026-67231?

Upgrade rabbitmq to a fixed version for your release line: 3.13.15, 4.0.20, 4.1.11 or 4.2.6.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-67231 being exploited?

There is no known exploitation of CVE-2026-67231 in the wild and no public exploit code.

All Broadcom Rabbitmq Server vulnerabilities

Sources

Also known as AZL-105290, BIT-rabbitmq-2026-67231, DEBIAN-CVE-2026-67231, GHSA-cw8c-4m83-9c6w, UBUNTU-CVE-2026-67231.

Is CVE-2026-67231 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free