# CVE-2026-67231: RabbitMQ: Trust-store whitelist by Issuer+Serial only

> Attackers can bypass TLS client authentication in RabbitMQ by forging certificates if the trust-store plugin is enabled and issuer/serial details are known.

- **Severity:** Critical 9.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** AZL-105290, BIT-rabbitmq-2026-67231, DEBIAN-CVE-2026-67231, GHSA-cw8c-4m83-9c6w, UBUNTU-CVE-2026-67231

## What is CVE-2026-67231?

CVE-2026-67231 is a critical authentication bypass vulnerability in Broadcom Rabbitmq Server, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, The trust-store plugin installs a verify_fun that overrides {bad_cert, unknown_ca} / {bad_cert, selfsigned_peer} when the presented cert "matches" a whitelisted one. The match key is extract_issuer_id/1 → public_key:pkix_issuer_id/2 → {IssuerName, SerialNumber} , both fields are taken verbatim from the presented certificate body and contain no public-key, SKI, fingerprint or signature material. is_whitelisted/1 is a pure ets:member lookup; the stored full DER is used only for list/0 display and is never compared against the presented cert. cacerts is [], so the whitelisted cert is never used as a trust anchor for path validation either. TLS client-authentication bypass: an attacker who knows the issuer DN + serial of any whitelisted certificate can connect with a forged self-signed cert. Preconditions include rabbitmq_trust_store plugin enabled and used as the TLS verify_fun Attacker knows or can guess the {Issuer, Serial} of at least one whitelisted cert (non-secret; exposed via CLI/logs/any cert copy). This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-67231?

1 open source package ship an affected version, including rabbitmq. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rabbitmq` | Bitnami | From 3.13.0 | 3.13.15, 4.0.20, 4.1.11, 4.2.6 |

Products: Broadcom Rabbitmq Server.

## How do I fix CVE-2026-67231?

Upgrade rabbitmq to a fixed version for your release line: 3.13.15, 4.0.20, 4.1.11 or 4.2.6.

## Is CVE-2026-67231 being exploited?

There is no known exploitation of CVE-2026-67231 in the wild and no public exploit code.

## Other vulnerabilities in Broadcom Rabbitmq Server

- [CVE-2016-9877](https://insights.sbomify.com/CVE-2016-9877/): Auth bypass in Pivotal RabbitMQ 3.x before 3.5.8 and 3.6.x before 3.6.6; RabbitMQ for PCF 1.5.x before 1.5.20, 1.6.x before 1.6.12 and 1.7.x before 1.7.7 (critical 9.8)
- [CVE-2026-67404](https://insights.sbomify.com/CVE-2026-67404/): RabbitMQ: OAuth2 silent verify_none fallback for JWKS fetch (critical 9.2)
- [CVE-2026-57219](https://insights.sbomify.com/CVE-2026-57219/): Information disclosure in rabbitmq-server (high 8.7)
- [CVE-2026-67236](https://insights.sbomify.com/CVE-2026-67236/): RabbitMQ: Plaintext username:password stored in an insecure cookie after successful POST /login (high 8.2)
- [CVE-2026-67409](https://insights.sbomify.com/CVE-2026-67409/): RabbitMQ: JWKS Fetch Ignores HTTP Response Status Code - Signing Key Destruction Causes Authentication DoS (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67231 and fix it if it is affected.

What it is: CVE-2026-67231 is a critical authentication bypass vulnerability in Broadcom Rabbitmq Server, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-67231 in the wild and no public exploit code.

Affected packages and fixed versions:
- rabbitmq (Bitnami): affected from 3.13.0; fixed in 3.13.15, 4.0.20, 4.1.11, 4.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67231/ (Markdown: https://insights.sbomify.com/CVE-2026-67231/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67231
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67231
- OSV: https://osv.dev/vulnerability/CVE-2026-67231

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67231/
Summaries are generated and may contain mistakes; the official description above is the record.
