CVE-2026-67232 RabbitMQ: Web-MQTT decompression bomb

High 8.2 Published Updated

An unauthenticated attacker can crash a RabbitMQ node by sending a compressed WebSocket frame that causes excessive memory consumption via decompression bomb.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-67232?

CVE-2026-67232 is a high-severity denial of service vulnerability in Broadcom Rabbitmq Server, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, The cowboy WebSocket options at line 117 set compress => true, enabling RFC 7692 permessage-deflate negotiation. The handler does not set max_frame_size, so cowboy's default of infinity applies. cowlib's cow_ws:parse_payload/9 calls zlib:inflate/2 on the compressed payload with no output-size limit. An attacker can negotiate permessage-deflate during the WebSocket upgrade and send a frame containing a zlib bomb (e.g. 50 KB → 5 GB). Decompression occurs in the connection process before websocket_handle/2 ever sees the MQTT bytes. An unauthenticated attacker can crash a RabbitMQ node running the Web-MQTT plugin by sending a single highly-compressed WebSocket frame (a few KB on the wire) that inflates to gigabytes in memory. The cowboy WebSocket handler decompresses the entire frame before the MQTT CONNECT packet is processed, so no credentials are required. Preconditions include rabbitmq_web_mqtt plugin enabled (not default, but common for browser clients) Network reachability to port 15675/15676 No authentication required. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0.

Weakness: CWE-409

Which versions are affected by CVE-2026-67232?

1 open source package ship an affected version, including rabbitmq. It affects 1 product.

PackageAffectedFixed in
rabbitmq BitnamiFrom 3.13.03.13.15, 4.0.20, 4.1.11, 4.2.6

Products include Broadcom Rabbitmq Server.

How do I fix CVE-2026-67232?

Upgrade rabbitmq to a fixed version for your release line: 3.13.15, 4.0.20, 4.1.11 or 4.2.6.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-67232 being exploited?

There is no known exploitation of CVE-2026-67232 in the wild and no public exploit code.

All Broadcom Rabbitmq Server vulnerabilities

Sources

Also known as AZL-105795, BIT-rabbitmq-2026-67232, DEBIAN-CVE-2026-67232, GHSA-gmgx-hhg5-43gr, UBUNTU-CVE-2026-67232.

Is CVE-2026-67232 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free