# CVE-2026-67238: RabbitMQ: Atom-table exhaustion via reply-to queue name decoding

> Authenticated attackers can crash the RabbitMQ Erlang VM by exhausting atoms via reply-to queue names, causing a denial of service.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Sep 2026
- **Updated:** 24 Sep 2026
- **Also known as:** BIT-rabbitmq-2026-67238, DEBIAN-CVE-2026-67238, GHSA-x96j-244m-mrr2, UBUNTU-CVE-2026-67238

## What is CVE-2026-67238?

CVE-2026-67238 is a high-severity denial of service vulnerability in rabbitmq-server, published on 23 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

RabbitMQ is a messaging and streaming broker. Prior to versions 4.2.7 and 4.3.1, rabbit_pid_codec:decompose_from_binary/1 parses a caller-supplied ETF-encoded binary and calls binary_to_atom(Node, utf8) on the node-name field. It is reached from rabbit_volatile_queue:pid_from_name/2, which is invoked for any queue name / routing key beginning amq.rabbitmq.reply-to.. The CandidateNodes membership check happens after the atom is created, and the surrounding try/catch cannot reclaim atoms (they are never GC'd). binary_to_existing_atom is not used. Any authenticated AMQP client can crash the entire Erlang VM (all vhosts, all connections) with ~1M cheap requests. Preconditions include Authenticated AMQP 0-9-1 connection to any vhost No per-connection rate limit low enough to make ~1M operations infeasible. This issue is fixed in versions 4.2.7 and 4.3.1.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-67238?

1 open source package ship an affected version, including rabbitmq.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rabbitmq` | Bitnami | From 4.2.0 | 4.2.7, 4.3.1 |

## How do I fix CVE-2026-67238?

Upgrade rabbitmq to a fixed version for your release line: 4.2.7 or 4.3.1.

## Is CVE-2026-67238 being exploited?

There is no known exploitation of CVE-2026-67238 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67238 and fix it if it is affected.

What it is: CVE-2026-67238 is a high-severity denial of service vulnerability in rabbitmq-server, published on 23 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-67238 in the wild and no public exploit code.

Affected packages and fixed versions:
- rabbitmq (Bitnami): affected from 4.2.0; fixed in 4.2.7, 4.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67238/ (Markdown: https://insights.sbomify.com/CVE-2026-67238/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67238
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67238
- OSV: https://osv.dev/vulnerability/CVE-2026-67238

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67238/
Summaries are generated and may contain mistakes; the official description above is the record.
