CVE-2026-67239 RabbitMQ: Stored XSS via TLS peer-certificate DN in stream-management UI
Stored XSS in RabbitMQ stream-management UI allows attackers to execute scripts in operators' browsers via malicious TLS certificate DNs.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-67239?
CVE-2026-67239 is a high-severity cross-site scripting vulnerability in Broadcom Rabbitmq Server, published on 25 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
RabbitMQ is a messaging and streaming broker. From 3.13.0 until 3.13.18 and 4.0.23 and 4.1.14 and 4.2.9 and 4.3.3, Stored XSS via TLS peer-certificate DN in stream-management UI (sibling of V-11). lines 102/106/110 render peercertsubject / peercertissuer with raw <%= %> and no fmtstring(). RFC4514 backslash-escaping of </> is HTML-inert and bypassable (<img ... //>). Requires non-default config: a stream TLS listener with verifypeer and an attacker-obtainable trusted cert with a malicious Same as the connection.ejs finding, against operators viewing the stream-connection detail rabbitmqstream + rabbitmqstreammanagement enabled with a TLS listener using verifypeer Attacker can obtain a certificate signed by a CA the listener trusts, with attacker-chosen DN An operator views the. This issue is fixed in versions 3.13.18 and 4.0.23 and 4.1.14 and 4.2.9 and 4.3.3.
Weakness: CWE-79
Which versions are affected by CVE-2026-67239?
1 open source package ship an affected version, including rabbitmq. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
rabbitmq Bitnami | From 3.13.0 | 3.13.18, 4.0.23, 4.1.14, 4.2.9, 4.3.3 |
Products include Broadcom Rabbitmq Server.
How do I fix CVE-2026-67239?
Upgrade rabbitmq to a fixed version for your release line: 3.13.18, 4.0.23, 4.1.14 or 4.2.9.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-67239 being exploited?
There is no known exploitation of CVE-2026-67239 in the wild and no public exploit code.
Other vulnerabilities in Broadcom Rabbitmq Server
- CVE-2016-9877 Auth bypass in Pivotal RabbitMQ 3.x before 3.5.8 and 3.6.x before 3.6.6; RabbitMQ for PCF 1.5.x before 1.5.20, 1.6.x before 1.6.12 and 1.7.x before 1.7.7
- CVE-2026-67404 RabbitMQ: OAuth2 silent verify_none fallback for JWKS fetch
- CVE-2026-67231 RabbitMQ: Trust-store whitelist by Issuer+Serial only
- CVE-2026-57219 Information disclosure in rabbitmq-server
- CVE-2026-67236 RabbitMQ: Plaintext username:password stored in an insecure cookie after successful POST /login
Sources
Also known as AZL-105756, BIT-rabbitmq-2026-67239, DEBIAN-CVE-2026-67239, GHSA-xm9p-57xv-vxwc, UBUNTU-CVE-2026-67239.