# CVE-2026-67240: RabbitMQ: ReDoS via AMQP 1.0 SQL filter LIKE wildcard


- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Sep 2026
- **Updated:** 24 Sep 2026
- **Also known as:** BIT-rabbitmq-2026-67240, DEBIAN-CVE-2026-67240, GHSA-59c5-553c-57m2, UBUNTU-CVE-2026-67240

## What is CVE-2026-67240?

CVE-2026-67240 is a low-severity vulnerability in rabbitmq-server, published on 23 Sep 2026. 

### Official description

RabbitMQ is a messaging and streaming broker. Prior to versions 4.2.7 and 4.3.1, pattern_to_regex maps % -> .*? and _ -> ., then compiles ^...$ with only [unicode]; re:run is called with only [{capture, none}] - no explicit match_limit. A pattern like %_%_..._%X becomes ^.*?..*?.....*?.X$ with overlapping lazy quantifiers. The whole-expression cap is ?MAX_EXPRESSION_LENGTH=4096 chars / ?MAX_TOKENS=200; a LIKE string literal is one token, so ~2000 %_ pairs fit. SQL filters are accepted unconditionally at rabbit_amqp_session.erl:3264 (no feature flag). Evaluated per-message at rabbit_stream_queue.erl:1439. OTP's default 10M match_limit caps each match at ~100-200 ms (not seconds), and the re NIF yields to the scheduler. An authenticated AMQP 1.0 consumer with read+write on a stream queue can cause ~100-200 ms of CPU per delivered message via a crafted LIKE filter, multiplied across thousands of messages and parallel sessions - a substantial backtracking-driven CPU amplification. Preconditions include AMQP 1.0 with stream queues in use Attacker can attach a receiver with a filter (read permission) and publish messages with long property values (write permission). This issue is fixed in versions 4.2.7 and 4.3.1.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-67240?

1 open source package ship an affected version, including rabbitmq.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rabbitmq` | Bitnami | From 4.2.0 | 4.2.7, 4.3.1 |

## How do I fix CVE-2026-67240?

Upgrade rabbitmq to a fixed version for your release line: 4.2.7 or 4.3.1.

## Is CVE-2026-67240 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67240 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67240 and fix it if it is affected.

What it is: CVE-2026-67240 is a low-severity vulnerability in rabbitmq-server, published on 23 Sep 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67240 exists.

Affected packages and fixed versions:
- rabbitmq (Bitnami): affected from 4.2.0; fixed in 4.2.7, 4.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67240/ (Markdown: https://insights.sbomify.com/CVE-2026-67240/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67240
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67240
- OSV: https://osv.dev/vulnerability/CVE-2026-67240

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67240/
Summaries are generated and may contain mistakes; the official description above is the record.
