# CVE-2026-67241: RabbitMQ: AMQP 1.0 management exchange.declare skips alternate-exchange permission check


- **Severity:** Medium 4.8 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:N/SC:L/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 25 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** BIT-rabbitmq-2026-67241, DEBIAN-CVE-2026-67241, GHSA-rg2g-289m-xhhw, UBUNTU-CVE-2026-67241

## What is CVE-2026-67241?

CVE-2026-67241 is a medium-severity vulnerability in Broadcom Rabbitmq Server, published on 25 Sep 2026. 

### Official description

RabbitMQ is a messaging and streaming broker. From 4.2.0 until 4.2.9 and 4.3.3, AMQP 1.0 management exchange.declare skips alternate-exchange permission check. pUT /exchanges/:name (lines 192-240) checks only configure on the declared exchange and passes XArgs straight to rabbitexchange:declare/7. It omits the checkreadpermitted(X) + checkwritepermitted(AE) that rabbitchannel.erl:2540-2548 enforces for the alternate-exchange argument on the AMQP 0-9-1 path. The same file already implements the analogous DLX check for queues (lines 708-719), confirming this is a missing-check bug rather than intentional A user with only configure on exchange X can route X's unroutable messages into an alternate exchange they have no write permission AMQP 1.0 enabled (default in RabbitMQ 4.x) Attacker has configure on at least one exchange but lacks write on the target. This issue is fixed in versions 4.2.9 and 4.3.3.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-67241?

1 open source package ship an affected version, including rabbitmq. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rabbitmq` | Bitnami | From 4.2.0 | 4.2.9, 4.3.3 |

Products: Broadcom Rabbitmq Server.

## How do I fix CVE-2026-67241?

Upgrade rabbitmq to a fixed version for your release line: 4.2.9 or 4.3.3.

## Is CVE-2026-67241 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67241 exists.

## Other vulnerabilities in Broadcom Rabbitmq Server

- [CVE-2016-9877](https://insights.sbomify.com/CVE-2016-9877/): Auth bypass in Pivotal RabbitMQ 3.x before 3.5.8 and 3.6.x before 3.6.6; RabbitMQ for PCF 1.5.x before 1.5.20, 1.6.x before 1.6.12 and 1.7.x before 1.7.7 (critical 9.8)
- [CVE-2026-67404](https://insights.sbomify.com/CVE-2026-67404/): RabbitMQ: OAuth2 silent verify_none fallback for JWKS fetch (critical 9.2)
- [CVE-2026-67231](https://insights.sbomify.com/CVE-2026-67231/): RabbitMQ: Trust-store whitelist by Issuer+Serial only (critical 9.1)
- [CVE-2026-57219](https://insights.sbomify.com/CVE-2026-57219/): Information disclosure in rabbitmq-server (high 8.7)
- [CVE-2026-67236](https://insights.sbomify.com/CVE-2026-67236/): RabbitMQ: Plaintext username:password stored in an insecure cookie after successful POST /login (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67241 and fix it if it is affected.

What it is: CVE-2026-67241 is a medium-severity vulnerability in Broadcom Rabbitmq Server, published on 25 Sep 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67241 exists.

Affected packages and fixed versions:
- rabbitmq (Bitnami): affected from 4.2.0; fixed in 4.2.9, 4.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67241/ (Markdown: https://insights.sbomify.com/CVE-2026-67241/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67241
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67241
- OSV: https://osv.dev/vulnerability/CVE-2026-67241

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67241/
Summaries are generated and may contain mistakes; the official description above is the record.
