# CVE-2026-67249: Apache Answer: Email Code Purpose Confusion May Allow Account Takeover

> Attackers can hijack user accounts by reusing verification codes across different email workflows due to missing purpose enforcement.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 19 Oct 2026
- **Updated:** 26 Oct 2026
- **Also known as:** GHSA-v85w-3rf6-qvhj

## What is CVE-2026-67249?

CVE-2026-67249 is a medium-severity authentication bypass vulnerability in Apache Answer, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A vulnerability in Apache Answer.

This issue affects Apache Answer: through 2.0.2.

A verification code issued for one email-based workflow could be accepted by another sensitive workflow because the code purpose was not properly enforced.

Users are recommended to upgrade to version 2.0.3, which fixes the issue.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-67249?


## How do I fix CVE-2026-67249?

No fix has been published for CVE-2026-67249 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-67249 being exploited?

There is no known exploitation of CVE-2026-67249 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67249 and fix it if it is affected.

What it is: CVE-2026-67249 is a medium-severity authentication bypass vulnerability in Apache Answer, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-67249 in the wild and no public exploit code.

Affected product: Apache Answer. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67249/ (Markdown: https://insights.sbomify.com/CVE-2026-67249/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67249
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67249
- OSV: https://osv.dev/vulnerability/CVE-2026-67249

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67249/
Summaries are generated and may contain mistakes; the official description above is the record.
