CVE-2026-67260 Apache Airflow: DAG-author remote code execution on the Scheduler via awaiting_input next_kwargs deserialization

High 7.3 Published Updated

A DAG author can achieve remote code execution or cause denial of service in the Apache Airflow scheduler via unsafe deserialization of task arguments.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-67260?

CVE-2026-67260 is a high-severity unsafe deserialization vulnerability in Apache Airflow, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Apache Airflow 3.3.0 moved human-in-the-loop tasks from the triggerer to a new `awaiting_input` task state swept by the scheduler. That sweep deserializes the task instance's `next_kwargs` without an allow-list, so a Dag author — who controls that value through the task execution API — can cause an arbitrary module import and object instantiation inside the scheduler process, or terminate the scheduler job. No non-default configuration is required: the sweep runs unconditionally every 15 seconds, and the default `allowed_deserialization_classes` setting does not cover this code path. Versions before 3.3.0 are not affected, because human-in-the-loop tasks deferred onto the triggerer instead. This is a different code path from CVE-2026-58076, which covers the same unguarded exception-node deserialization reached elsewhere — deployments that applied that fix must upgrade for this issue as well. Users are advised to upgrade to apache-airflow 3.3.1 or later.

Weakness: CWE-502

Which versions are affected by CVE-2026-67260?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.

PackageAffectedFixed in
apache-airflow PyPIFrom 3.3.03.3.1
apache-airflow PyPIFrom 3.3.03.3.1
apache-airflow PyPIFrom 3.3.03.3.1
airflow BitnamiFrom 3.3.03.3.1

Products include Apache Airflow.

How do I fix CVE-2026-67260?

Upgrade apache-airflow to 3.3.1 or later.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2026-67260 being exploited?

There is no known exploitation of CVE-2026-67260 in the wild and no public exploit code.

All Apache Airflow vulnerabilities

Sources

Also known as BIT-airflow-2026-67260, GHSA-q4c3-7575-55j2, MINI-c62j-r75r-7ppq, PYSEC-2026-3707.

Is CVE-2026-67260 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free