# CVE-2026-67260: Apache Airflow: DAG-author remote code execution on the Scheduler via awaiting_input next_kwargs deserialization

> A DAG author can achieve remote code execution or cause denial of service in the Apache Airflow scheduler via unsafe deserialization of task arguments.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Aug 2026
- **Updated:** 16 Sep 2026
- **Also known as:** BIT-airflow-2026-67260, GHSA-q4c3-7575-55j2, MINI-c62j-r75r-7ppq, PYSEC-2026-3707

## What is CVE-2026-67260?

CVE-2026-67260 is a high-severity unsafe deserialization vulnerability in Apache Airflow, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Airflow 3.3.0 moved human-in-the-loop tasks from the triggerer to a new `awaiting_input` task state swept by the scheduler. That sweep deserializes the task instance's `next_kwargs` without an allow-list, so a Dag author — who controls that value through the task execution API — can cause an arbitrary module import and object instantiation inside the scheduler process, or terminate the scheduler job. No non-default configuration is required: the sweep runs unconditionally every 15 seconds, and the default `allowed_deserialization_classes` setting does not cover this code path. Versions before 3.3.0 are not affected, because human-in-the-loop tasks deferred onto the triggerer instead. This is a different code path from CVE-2026-58076, which covers the same unguarded exception-node deserialization reached elsewhere — deployments that applied that fix must upgrade for this issue as well. Users are advised to upgrade to apache-airflow 3.3.1 or later.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-67260?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | From 3.3.0 | 3.3.1 |
| `apache-airflow` | PyPI | From 3.3.0 | 3.3.1 |
| `apache-airflow` | PyPI | From 3.3.0 | 3.3.1 |
| `airflow` | Bitnami | From 3.3.0 | 3.3.1 |

Products: Apache Airflow.

## How do I fix CVE-2026-67260?

Upgrade apache-airflow to 3.3.1 or later.

## Is CVE-2026-67260 being exploited?

There is no known exploitation of CVE-2026-67260 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67260 and fix it if it is affected.

What it is: CVE-2026-67260 is a high-severity unsafe deserialization vulnerability in Apache Airflow, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-67260 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected from 3.3.0; fixed in 3.3.1
- apache-airflow (PyPI): affected from 3.3.0; fixed in 3.3.1
- apache-airflow (PyPI): affected from 3.3.0; fixed in 3.3.1
- airflow (Bitnami): affected from 3.3.0; fixed in 3.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67260/ (Markdown: https://insights.sbomify.com/CVE-2026-67260/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67260
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67260
- OSV: https://osv.dev/vulnerability/CVE-2026-67260

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67260/
Summaries are generated and may contain mistakes; the official description above is the record.
