# CVE-2026-67310: openremote before 1.27.0 Cross-Tenant IDOR via setAssetLinks

> An authenticated attacker can bypass realm checks to link assets across tenants, disclosing victim asset names and modifying links.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 1 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-4f8w-fmh5-hcxr, GHSA-q2gm-frx3-2qjr

## What is CVE-2026-67310?

CVE-2026-67310 is a medium-severity missing authorization vulnerability in openremote, published on 1 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenRemote (org.openremote:openremote) versions <= 1.26.2 contain an insecure direct object reference vulnerability in the setAssetLinks endpoint of AlarmResourceImpl. The realm access check validates only a single realm obtained via realms.stream().findFirst() on a HashSet of realms from the request, rather than all realms. Because HashSet iteration order is non-deterministic, an authenticated attacker who includes alarm-asset links from both their own realm and a victim realm can, with roughly 50% probability per request (retryable), persist cross-tenant links and disclose victim asset names (returned via @Formula fields) through GET requests on the attacker's own alarm. Fixed in 1.27.0.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-67310?


## How do I fix CVE-2026-67310?

No fix has been published for CVE-2026-67310 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-67310 being exploited?

There is no known exploitation of CVE-2026-67310 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67310 and fix it if it is affected.

What it is: CVE-2026-67310 is a medium-severity missing authorization vulnerability in openremote, published on 1 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-67310 in the wild and no public exploit code.

Affected product: openremote. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67310/ (Markdown: https://insights.sbomify.com/CVE-2026-67310/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67310
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67310
- OSV: https://osv.dev/vulnerability/CVE-2026-67310

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67310/
Summaries are generated and may contain mistakes; the official description above is the record.
