CVE-2026-67312 axios 0.28.0 before 0.33.0 and 1.0.0 before 1.18.0 Denial of Service via formToJSON
Attackers can cause denial of service in applications using axios by sending FormData with deeply nested field names, triggering stack exhaustion.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-67312?
CVE-2026-67312 is a medium-severity denial of service vulnerability in axios, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
axios versions from 0.28.0 before 0.33.0 and from 1.0.0 before 1.18.0 contain uncontrolled recursion in formDataToJSON (exposed as axios.formToJSON() and used internally when serializing FormData with Content-Type: application/json). When an application passes attacker-controlled FormData field names, a field name with thousands of nested bracket-delimited segments causes unbounded recursion in buildPath(), exhausting the JavaScript call stack (RangeError: Maximum call stack size exceeded) and causing denial of service for that request, or process termination in applications without appropriate error handling.
Weakness: CWE-400
Which versions are affected by CVE-2026-67312?
4 open source packages ship an affected version, including axios. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
axios npm | From 0.28.0 | 0.33.0 |
axios npm | From 0.28.0 | 0.33.0 |
axios npm | From 1.0.0 | 1.18.0 |
axios npm | From 1.0.0 | 1.18.0 |
Linux distribution packages (1)
python-nbdime openSUSE:Tumbleweed | All versions | 4.0.4-24.1 |
Products include Axios Axios.
How do I fix CVE-2026-67312?
Upgrade axios to a fixed version for your release line: 0.33.0 or 1.18.0.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-67312 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67312 exists.
Other vulnerabilities in axios
- CVE-2026-44494 Axios: Full Man-in-the-Middle via Prototype Pollution Gadget in `config.proxy`
- CVE-2026-44492 axios's shouldBypassProxy does not recognize IPv4-mapped IPv6 addresses, allowing NO_PROXY bypass (incomplete fix for CVE-2025-62718)
- CVE-2026-67320 axios before 0.33.0 Prototype Pollution via Node HTTP adapter
- CVE-2026-44487 Axios: Proxy-Authorization Credential Leak to Origin Server Across HTTP-to-HTTPS Redirect in Axios Node.js HTTP Adapter
- CVE-2025-27152 Possible SSRF and Credential Leakage via Absolute URL in axios Requests
Sources
Also known as CLEANSTART-2026-XJ62006, CVE-2026-68941, DEBIAN-CVE-2026-67312, ECHO-c23a-28c1-335e, GHSA-pmv8-rq9r-6j72, MINI-362m-j2ww-594r and 28 more.