# CVE-2026-67312: axios 0.28.0 before 0.33.0 and 1.0.0 before 1.18.0 Denial of Service via formToJSON

> Attackers can cause denial of service in applications using axios by sending FormData with deeply nested field names, triggering stack exhaustion.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2026
- **Updated:** 29 Oct 2026
- **Also known as:** CLEANSTART-2026-XJ62006, CVE-2026-68941, DEBIAN-CVE-2026-67312, ECHO-c23a-28c1-335e, GHSA-pmv8-rq9r-6j72, MINI-362m-j2ww-594r, MINI-47c6-j53g-g9rq, MINI-599c-357m-7893, MINI-5cvf-gjqf-h92h, MINI-5h4q-8vrp-w85g, MINI-5hj6-jxpf-gwj9, MINI-5x49-vpqj-qg8x, MINI-6x89-3mx8-6wp5, MINI-7j92-p2hq-x74x, MINI-7pg9-2xqm-8cmm, MINI-8493-rcvc-m77h, MINI-ffq6-9v5r-2mh5, MINI-hp4g-83hm-6v9v, MINI-m238-79xw-x23f, MINI-m694-35gc-ccg8, MINI-m934-998f-6h9m, MINI-m9g7-f573-93g9, MINI-mgm9-4395-97hx, MINI-p8pm-f48q-hr42, MINI-q9gp-pvqp-qxr6, MINI-qjq2-vx7q-56h6, MINI-r4jr-v2m6-rwm3, MINI-rjjr-vxx6-r4c7, MINI-wq29-vxwg-2g3m, MINI-x49j-4m2m-h33w, ROOT-APP-NPM-CVE-2026-67312, ROOT-APP-NPM-GHSA-pmv8-rq9r-6j72, UBUNTU-CVE-2026-67312, openSUSE-SU-2026:11458-1

## What is CVE-2026-67312?

CVE-2026-67312 is a medium-severity denial of service vulnerability in axios, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

axios versions from 0.28.0 before 0.33.0 and from 1.0.0 before 1.18.0 contain uncontrolled recursion in formDataToJSON (exposed as axios.formToJSON() and used internally when serializing FormData with Content-Type: application/json). When an application passes attacker-controlled FormData field names, a field name with thousands of nested bracket-delimited segments causes unbounded recursion in buildPath(), exhausting the JavaScript call stack (RangeError: Maximum call stack size exceeded) and causing denial of service for that request, or process termination in applications without appropriate error handling.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-67312?

4 open source packages ship an affected version, including axios. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `axios` | npm | From 0.28.0 | 0.33.0 |
| `axios` | npm | From 0.28.0 | 0.33.0 |
| `axios` | npm | From 1.0.0 | 1.18.0 |
| `axios` | npm | From 1.0.0 | 1.18.0 |
| `python-nbdime` | openSUSE:Tumbleweed | All versions | 4.0.4-24.1 |

Products: Axios Axios.

## How do I fix CVE-2026-67312?

Upgrade axios to a fixed version for your release line: 0.33.0 or 1.18.0.

## Is CVE-2026-67312 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67312 exists.

## Other vulnerabilities in axios

- [CVE-2026-44494](https://insights.sbomify.com/CVE-2026-44494/): Axios: Full Man-in-the-Middle via Prototype Pollution Gadget in `config.proxy` (high 8.7)
- [CVE-2026-44492](https://insights.sbomify.com/CVE-2026-44492/): axios's shouldBypassProxy does not recognize IPv4-mapped IPv6 addresses, allowing NO_PROXY bypass (incomplete fix for CVE-2025-62718) (high 8.6)
- [CVE-2026-67320](https://insights.sbomify.com/CVE-2026-67320/): axios before 0.33.0 Prototype Pollution via Node HTTP adapter (high 8.3)
- [CVE-2026-44487](https://insights.sbomify.com/CVE-2026-44487/): Axios: Proxy-Authorization Credential Leak to Origin Server Across HTTP-to-HTTPS Redirect in Axios Node.js HTTP Adapter (high 8.2)
- [CVE-2025-27152](https://insights.sbomify.com/CVE-2025-27152/): Possible SSRF and Credential Leakage via Absolute URL in axios Requests (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67312 and fix it if it is affected.

What it is: CVE-2026-67312 is a medium-severity denial of service vulnerability in axios, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67312 exists.

Affected packages and fixed versions:
- axios (npm): affected from 0.28.0; fixed in 0.33.0
- axios (npm): affected from 0.28.0; fixed in 0.33.0
- axios (npm): affected from 1.0.0; fixed in 1.18.0
- axios (npm): affected from 1.0.0; fixed in 1.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67312/ (Markdown: https://insights.sbomify.com/CVE-2026-67312/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67312
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67312
- OSV: https://osv.dev/vulnerability/CVE-2026-67312

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67312/
Summaries are generated and may contain mistakes; the official description above is the record.
